Jamf wants access to control "System Events" PPPC

DennisMX
Contributor

Hi,

We need to deploy the Xerox Workplace Cloud client, but while doing so it is displaying the message in the title.
I've used the PPPC Utility to get rid of it, but it doesn't work.

I've build the PPPC as LPARNELL here: https://community.jamf.com/t5/jamf-pro/quot-jamf-quot-wants-access-to-control-quot-system-events-quo...

But still it doesn't work.

When enabling Big Sur compatibiltity in the PPPC Utility the deployment of the PPPC profile will fail instantly.
anyone got an idea how to fix it?

5 REPLIES 5

junjishimazaki
Contributor II

@DennisMX how are you deploying that PPPC?

TheWarmAtlantic
New Contributor III

go through each entry and resave once you upload to Jamf. this will change the "allow standard user to approve" to "allow". that still didn't fix the issue for me. I had this working just fine with my current PPPC profiles but something has changed with Big Sur 11.4

DennisMX
Contributor

@junjishimazaki I just uploaded it using the PPPC tool and scoped it to a test machine.

The profile where i did not enable the Big Sur Compatibility removed the nasty pop-up now, so my pop-up issue is fixed. But the PPPC Profle with Big Sur Compatibility enabled is still failing to deploy.

are you running 11.4? can your share your profile.

I could share it, if i not reinstalled the machine before properly saving it...

You probably have the same issue as i had, since the app you try to install uses a nasty osascript.
When manually approving it seems like Big Sur has an Automation section, which isn't in Jamf (Where is that 0-day support when you need it??)

To make it work i did this:

to the left side drag the Jamf and JamfManagementService from \Library\Application Support\JAMF\Jamf\Content\MacOS
Also drag the Jamf.app from  \Library\Application Support\JAMF to the left.

Next find osascript in /usr/bin and also drag it to the left.

In the middle column set Accessibility to Allow.
In the right column add All options (i think it is System Events, SystemUI something and Finder).
Now also for each app on the left add it to the right side, making every app allowing to use the other (makes sense right?)

I did not enable Big Sur compatibility as it work break the deployment of it.
It is probably overkill, but this made it work for me