JDS fails to install -- ERROR cannot get UUID

New Contributor III

So I keep encountering the following error when I attempt to run the JDS installer:

Allow untrusted SSL certificate? (y/n): y Could not get UUID failed to create configuration file. check /usr/local/jds/logs/jamf.log for more information.

the log listed only reports:

2013-12-09 18:51:58,189 ERROR Could not get UUID 2013-12-09 18:55:52,851 ERROR Could not get UUID 2013-12-09 18:59:44,011 ERROR Could not get UUID 2013-12-09 19:04:37,457 ERROR Could not get UUID

Any thoughts? Rackin' my brain over this one.


Contributor III

What OS are you attempting to install on? Is this a VM or physical server?

New Contributor III

Hi Kraig, try to install dmidecode on the server using yum install dmidecode or apt-get install dmidecode. I've seen issues where that piece isn't present on the server and the installer will fail.

New Contributor III

@johnkitzmiller This is a ubuntu 12.04 virtual machine running on xen (open source).

@beckerbm thanks for the tip -- same error, i'm afraid.

New Contributor

Hey Kraig, what do you get if you run ```
dmidecode --type 1
for example my ubuntu 12.04 vm gives me

dmidecode 2.11

SMBIOS 2.3 present.

Handle 0x0001, DMI type 1, 25 bytes
System Information Manufacturer: Parallels Software International Inc. Product Name: Parallels Virtual Platform Version: None Serial Number: Parallels-E9 BD 33 40 E7 19 45 2E 00 30 EE A1 FE F9 64 00 UUID: AAAAAAAA-BBBB-CCCC-DDDD-FFFFFFFFFFFF Wake-up Type: Power Switch
the JDS runs that command and picks out the UUID field.

New Contributor III

@eric.hutter ah. So that will be part of the problem then:

# dmidecode 2.11 # No SMBIOS nor DMI entry point found, sorry.

New Contributor III

I started over hosting the server on hyper-v instead of the xen server I was using and it installed fine.

I'm guessing that the reason for the error was that SMBIOS wasn't being populated in the paravirt images that my xen hosts are deploying. And politically, trying to get a xen server to start as a hvm in my org is impossible. Waaa.


I had the same problem yesterday:

JDS did not install correctly on an Ubuntu vm with the same error, not getting a UUID.

# dmidecode 2.11
# No SMBIOS nor DMI entry point found, sorry.

As it seems that this is dependent on the virtualization engine, the problem seems to be identified.
In this case I am only running the vm, not the host - So I contacted the support of the hosting company and they suggested using


instead of dmidecode. On the vm, I tried:

root@somehost:~# blkid
/dev/xvda: UUID="72fcbee1-275c-4bd0-8861-0bf4a0987acd" TYPE="ext4" /dev/xvdb: LABEL="swap" TYPE="swap"

So it seems, that there is a way to obtain the UUID. It could be nice if the Installer could be modified to use blkid if dmidecode fails.


I have added a feature request for a possible solution at: