JDS Replication Error

Contributor III

When trying to do a replication to the JDS from Casper Admin, we are getting this error:
"There was a problem connecting to the server "utasjdssby.its.utas.edu.au". This file server will not allow any additional users to log on. Try to connect again later"

Strange thing is that the share actually mounts on the computer running Casper Admin.

I have restarted the JDS with no change in behaviour, this has replicated in the past with no errors.

Log entry from ~/Library/Logs/Casper Admin Sync Log.log:
-- Replicating to distribution point https://utasjdssby.its.utas.edu.au/CasperShareDAV 30/09/13 9:49 AM --
2013-09-30 09:49:35: Comparing files based on size
2013-09-30 09:49:35: Mounting https://utasjdssby.its.utas.edu.au/CasperShareDAV...
2013-09-30 09:53:16: ERROR: The distribution point could not be mounted. The replication operation will stop
2013-09-30 09:53:16: Finished.
-- Unmounting https://utasjdssby.its.utas.edu.au/CasperShareDAV 30/09/13 9:53 AM --

Anyone have some ideas as to what is going on?


New Contributor

Do you have Websites ON for Port 443 in OS X Server? The JDS uses WebDAV to communicate. I received the same message until turning Websites ON.

Contributor III

Andrew, the JDS in this instance is a Redhat VM. Yes the correct ports are open in the firewall.

It was working last week, don't know what changed over the weekend.

Contributor III

Also having this problem. JDS is on a Mac OS X 10.8.4. This was also working last week.
Edit: Just restarted the JDS and it is working again.

New Contributor II

@dmw3 - Any luck on this. I am experiencing the same issue. I am thinking it may have to do with my certs now.

I can mount my caspershare a bunch of different ways:


I just can't mount it with DAV on the end.

Contributor III
Contributor III

Just installed JDS on CentOS 6.5 Minimal and it's reporting to the JSS properly but I get the same error.

-- Replicating to distribution point  https://casperjds.serv/CasperShareDAV  5/13/14 6:05 PM --
2014-05-13 18:05:08: Comparing files based on size
2014-05-13 18:05:08: Mounting https://casperjds.serv/CasperShareDAV...
2014-05-13 18:05:18: ERROR: The distribution point could not be mounted. The replication operation will stop
2014-05-13 18:05:18: Finished.
-- Unmounting https://casperjds.serv/CasperShareDAV  5/13/14 6:05 PM --

I can't replicate to this JDS and I'm not sure what needs to be fixed.

Contributor III

Not sure if this is related to the issue you are seeing but I ran into the issue /url">@nzmacgeek][/url mentions in his feature request here: [https://jamfnation.jamfsoftware.com/featureRequest.html?id=1886

*EDIT* I see you mentioned that it was working properly before. I know in our case any large packages over ~1.2gb would fail due to insufficient space in the /tmp/ folder. I ended up manually copying the larger files to the server and then moving them into the JDS share folder and updating inventory on the JDS so that it would stop attempting to copy them over and continue with the remaining files that were small enough to be staged on the /tmp/ drive. Probably not related to the issue you are seeing but thought I would throw it out there just in case.

Contributor III
Contributor III

@FritzsCorner, that's a great feature request and I just up-voted it. I ran into that issue on my first build out of the Cent OS virtual machine with two virtual hard drives. When I started over I built out one large virtual hard drive and had to resize the logical volumes. All that aside, I finally got the JDS reporting the full size of the virtual hard drive and then I went to replicate from my primary distribution point to this new JDS and got the error that I posted previously. I don't know if CentOS 6.5 minimal is missing an essential service/application for the JDS to communicate properly.

Contributor III
Contributor III

For the sake of troubleshooting I built out the vm in the recommended Ubuntu 12.04 lts server OS. I cannot get it to work whatsoever. The building process goes extremely smooth and the JDS reports properly to the JSS, but when I attempt to replicate I get the error posted above. Cannot mount the share. I have followed JAMF's directions 100% and even rebuilt the entire VM four times to make sure I wasn't missing one small step. The results are the same each time.