Keychain minder


I am trying to test keychain minder, but how do I install keychain?.
I have downloaded the files, but I am unable to find any instructions how to install this as there is no installation file like other programs. So guess they must be placed the files directly in some structure, but where ?



EDIT: I am trying to test keychain minder, but how do I install keychain minder?


Did you try here?

Valued Contributor

Keychain Minder is old, outdated software. You should look for a newer alternative, such as NoMad.


I have already found the link to the software, but where is the installation instruction ?

Keychain minder was just mentioned in Nomad webinar in august - So guess it is still usable. I am using nomad, but a far I can see it does not any keychain "friendlyness"

Valued Contributor

The NoMAD developer(s) are giving KeychainMinder a slight makeover; It's in beta and in roll-your-own state. You'll probably need to create a launch agent to run it.

Hop on the NoMAD Slack channel and you'll find others talking about it.

Release Candidate Programs Tester

There's a few KeychainMinder projects.. which is fun!

  • The OG Keychain Minder of yore.. written by @mactroll
  • The Google Keychain Minder project, as linked above.
  • The NoMAD Keychain Minder project.. resurrected by @mactroll

Just to try to ease the confusion.

New Contributor III

@rossoneris Scroll down the page to the Installation section and there is a link to the release page.


I attempted a deployment of the Google KeychainMinder project (v1.6) and I found that it wasn't prompting my test machine to sync passwords. I tried to launch the GUI that gets called by the LaunchAgent manually, and nothing popped up.

I then tried to run the executable that is being called by the LaunchDaemon, and it just sits there until I ctrl-c it.

Finally, I tried to run the KeychainMinder executable (found at /Library/Security/SecurityAgentPlugins/KeychainMinder.bundle/Contents/MacOS) and I get:

./KeychainMinder: cannot execute binary file

Anyone else experienced this? My test machine is running 10.12.6.