Large pkg upload failures

rpayne
Contributor II

Has anyone else encountered failures when uploading large files? I have been attempting to upload a pkg containing the installer for Catalina to our instance and the upload keeps failing.

We have a cloud instance. I have renamed the file multiple times. I have tried in Jamf admin AND directly through the Jamf pro Webb interface. I've tried it remote from my home office (gigabit fiber) both wired/wireless, and from both wired/wireless in office. I have had this happen in the past and it was never resolved. The pkg in question is 7.7gb. It has done the same with 2+gb files as well (office pkgs).

84 REPLIES 84

sumitjha
New Contributor II

I am chasing the same from last few weeks, i have renamed the file etc did lots but there is not fix yet received. Still getting error 504 when replicating DP to JAMF Cloud.

As well as getting error 400 when executing the policy when i tried to upload the package from GUI.

rusty_adams
New Contributor II

Anecdotal, but we recently migrated to JamfCloud from on-prem. We were having some trouble getting large packages to upload, remembered a Mac vs Windows discussion here and switched to a Windows pc. That worked for a slightly over 1GB package but still had multiple failures on a ~7GB Adobe CC package. Renamed it (taking out underscores, spaces, etc.) and it uploaded. No idea if that was a solution, or it just decided to work that time.

stutz
Contributor

Anyone else having an issue uploading Xcode 12.4 to their JAMF Cloud through the web console? Tried probably 7 times and fails each time. Tried renaming, repackaging. Takes like 2+ hours each try and you don't get notified of the package failure until the end.

tomt
Valued Contributor

Lately I've actually had luck using the Jamf Admin app for large packages. Even though Jamf says not to use it...

sdagley
Honored Contributor III

@stutz Take a look at pkgChunker. Do NOT try to use the installer, just download and run the script. You might also want to adjust the chunk size used in the script to something smaller Tham 7GB.