Location Services being skipped; JAMF 26 Big Sur ARM based

dugnl
New Contributor III

In the prestage, location services is unchecked. It should not be skipped.

Yet, the ARM based Big Sur version 26 JAMF is skipping this process. As a result, my ARM Macs are on California time.

Workaround?

21 REPLIES 21

Tribruin
Valued Contributor
Valued Contributor

Are you using Jamf Connect or skipping user creation during setup and creating users some other way? I have seen this issue on my Intel Big Sur with JC. Apparently there is a bug (or maybe not a bug) when the user not created during setup. In pre-Big Sur, a user created by JC or another method would prompt the user during first login for Location Services. but that seems to have changed in Big Sur. Very annoying.

jgaitherccu
New Contributor III

This is happening to us with Big Sur whether it's M1 or Intel. Location Services, even when unchecked in the Enrollment, is being skipped. Same enrollment works fine for Catalina and below. Until we find some fix we're just having to remember to go in to Privacy and turn Location Services on manually.

dtmille2
Contributor III

I've noticed this with Big Sur as well with PreStages that should allow it.

peternbevan
New Contributor III

Yeah - same here, although this mess-up pales into insignificance compared to 11.0.0 recovery partition being unable to restore the macOS onto a wiped M1 machine. What a joke.

jgaitherccu
New Contributor III

@peternbevan From a previous post of mine:
Just got off a chat with Apple Support and this worked for me: https://support.apple.com/en-us/HT211983

Specifically Steps 1-9 under Prepare Your Mac. For some reason wiping it from resetpassword in Terminal made the difference and we were able to reinstall the OS after that.

dugnl
New Contributor III

Thank you all, glad it's not me.

And yes, both our ARM Macs (MacBook and Air), give us the "no users available for authorization" and we have to reset password. And then I have to do it twice because the first time, it won't mount the drive.

It also seems like all the privacy settings I employed to stop apps from asking for control or access to, also aren't working with ARM Big Sur. Prompt after prompt after prompt. The policies are there. Those same policies work fine on Intel Big Sur.

Day one headaches for us.

snowfox
Contributor III

@dugnl Have you tried setting timezone and time server in a provisioning script instead? I had to do this for our machines as we have users travelling to multiple countries. Setting the timezone and time server using a config profile locks the settings for the user so i had to use a script instead to initially set it and then they can still change it if they wish or are travelling etc. Systemsetup command still works for me on Intel 11.0.1, don't know about ARM64 devices.

#--------------------------------------------------------
# Set the Mac timezone & timeservers
#--------------------------------------------------------

# Set the timezone
systemsetup -settimezone Europe/London

# Set the timeservers
systemsetup -setnetworktimeserver time.euro.apple.com

# Enables the Mac to set its clock using the network time server(s)
systemsetup -setusingnetworktime on

# The below command will list all available timezones
# systemsetup -listtimezones

jgaitherccu
New Contributor III

@snowfox Your script worked on my M1 Big Sur machine so it still works! Unfortunately it only fixes half of my problem. It used to be the Location Services was a choice during setup. You could check the box and hit next and be good to go. As of Big Sur, Enrollment ignores that option.

But at least you've helped me find a solution for the stupid clock!

fimi
New Contributor III

Having the same issue. Any fix for this making it work out of box? Sure it can be fixed manually/with a script.

nixsky
New Contributor II

Anyone know if Jamf have any plans to resolve this?

koszyczj
New Contributor III

I had opened a support ticket on this a few weeks ago and was told it was a known issue logged under PI-009049. I was also told that JAMF has a ticket open with Apple Enterprise Support and that there is currently no ETA. Sounds like it might originate on Apples end.

sdagley
Honored Contributor III

This script fragment will enable Location Services, and automatic timezone setting. I've been using it for a few years, and it's still working on Big Sur, but does require a restart before everything is enabled. I didn't write it myself, and I don't recall exactly where I found it, but I'm pretty sure it was from a Jamf Nation post.

# enable location services
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd LocationServicesEnabled -int 1
uuid=$(/usr/sbin/system_profiler SPHardwareDataType | grep "Hardware UUID" | cut -c22-57)
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd.$uuid LocationServicesEnabled -int 1

# enable automatic timezone selection
/usr/bin/defaults write /Library/Preferences/com.apple.timezone.auto Active -bool YES
/usr/bin/defaults write /private/var/db/timed/Library/Preferences/com.apple.timed.plist TMAutomaticTimeOnlyEnabled -bool YES
/usr/bin/defaults write /private/var/db/timed/Library/Preferences/com.apple.timed.plist TMAutomaticTimeZoneEnabled -bool YES

/usr/sbin/systemsetup -setusingnetworktime on
/usr/sbin/systemsetup -gettimezone
/usr/sbin/systemsetup -getnetworktimeserver

dstranathan
Valued Contributor II

I'm having the same issue on both M1 and Intel Big Sur 11.2 deployments.

Location picker is skipped during Setup Assistant even though it's enabled in the PreStage.

Once enrolled/deployed the Macs time is a few hours off from my time zone.

I also added a script to set NTP server, time zone, and location at enrollment time. Works for now.

<pun>Good times </pun>

fimi
New Contributor III

@sdagley

Thanks for the script. Works perfectly after a manual restart. Just needs a minute or so to pick up the location.

Though Jamf needs to fix this.

kicasper
New Contributor

There is an open ticket for this one, PI-009049

stephaniemm77
Contributor

@sdagley

Thank you for that script, did you just add it as a policy?

colorenz
Contributor

@stephaniemm77 yes you can add it as a policy.

bwoods
Valued Contributor

Package the following script and deploy it at enrollment.

#!/bin/bash
#configure ntp server
/bin/cat > /etc/ntp.conf << 'NEW_NTP_CONF'
server time.apple.com
NEW_NTP_CONF

#configure automatic timezone
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd LocationServicesEnabled -int 1

uuid=$(/usr/sbin/system_profiler SPHardwareDataType | grep "Hardware UUID" | cut -c22-57)
/usr/bin/defaults write /var/db/locationd/Library/Preferences/ByHost/com.apple.locationd.$uuid LocationServicesEnabled -int 1

#Set date and time automatically
/usr/bin/defaults write /Library/Preferences/com.apple.timezone.auto Active -bool YES
/usr/bin/defaults write /private/var/db/timed/Library/Preferences/com.apple.timed.plist TMAutomaticTimeOnlyEnabled -bool YES
/usr/bin/defaults write /private/var/db/timed/Library/Preferences/com.apple.timed.plist TMAutomaticTimeZoneEnabled -bool YES
/usr/sbin/systemsetup -setusingnetworktime on
/usr/sbin/systemsetup -gettimezone
/usr/sbin/systemsetup -getnetworktimeserver

#Restart location services daemon (locationd)
/usr/bin/killall locationd

exit 0; ## Success
exit 1; ## Failure

I tried this on Monterey 12.1.  In the System Preferences GUI the set time zone automatically is now checked but it is not actually changing the time zone until I reboot.

I had to add this line at the end before the exit lines

#Restart time daemon (timed)
/usr/bin/killall timed

 

Now it is updating immediatley. 

garybidwell
Contributor III

I didn’t see it mentioned in the developer release notes, but updating our test environment to test macOS 11.4 developer beta 2 last week brought the location services option back.

echave
New Contributor III

Can confirm. M1 with 11.3.1 doesn't show Locations Settings during initial setup. Erase install of 11.5.1 and it's shown.