Mac Office 2016 slow to start. Anyway to disable it trying to connect with internet?

Bernard_Huang
Contributor III

Hi all,

We have Office 2016 running in our Macbook for quite a while now. Since more and more people are using it, there's now quite a noise about it regarding Excel, Word, and PowerPoint starting up slow.

From my investigation, I have found:
- If I open excel, powerpoint, or word normally within our company's network, it takes 2 mins each to open.
- If I disconnect the Macbook from any network (no ethernet, no wifi), then excel, powerpoint, word will start instantaneously (around 5 secs)
- If I connect the Macbook to an external network (eg: connect from home), then again excel, powerpoint, and work start instantaneously.

Bases on my experiments above, it suggest to me that Microsoft office applications, each of them will try to connect to the internet first. Our office's internet proxy must be stopping it from succeeding, therefore it gives up after 2 minutes then starts.

So my actual question is: Is there a way to disable this internet connectivity attempt at the start? Any files to update or any switches I can turn off?

8 REPLIES 8

Swift
New Contributor II

We add the following line to the /etc/hosts file to prevent internet access.

127.0.0.1 prod-w.nexus.live.com.akadns.net odc.officeapps.live.com omextemplates.content.office.net officeclient.microsoft.com

We need to add this line to the /etc/hosts file in order to prevent the 365 login box appearing - since office gets confused when behind an internet proxy. Maybe it will help the slow start too.

Bernard_Huang
Contributor III

Thanks Swift,

But no cigar I'm afraid. I edited my /etc/host file. Then restarted my Macbook. Still, Excel or Word or Powerpoint all wait for 2 minutes to start up.

I wonder how office 2016 knows if I have internet connection or not. One of my test case was switching off all internet connection, and it starts up fine.

cgolebio
New Contributor III

Hey,
So pbowden on MacAdmins slack posted this helpful article and how to reduce it by setting plist values. It is all in the document. Hope you find it helpful as I know it did for me.

From: pbowden

A little overdue, but finally got around to writing up the list of network end-points we contact in Office 2016 for Mac, a description of what we get from (or send to) each end-point, and options for reducing the amount of traffic. As always, let me know if you have any questions. http://macadmins.software/docs/Network_Traffic.pdf

Swift
New Contributor II

Hi
Try modifying the /etc/hosts file to include the URLs from the "First App Launch" section of the very useful article mentioned by cgolebio above. I have updated my own hosts file to prevent ongoing proxy issues as folows:

127.0.0.1   prod-w.nexus.live.com.akadns.net odc.officeapps.live.com omextemplates.content.office.net officeclient.microsoft.com store.office.com nexusrules.officeapps.live.com nexus.officeapps.live.com

daz_wallace
Contributor III
Contributor III

Hi @huangbe

The list of URLs I found at a clients site are:

  • nexus.officeapps.live.com
  • ocos-office365-s2s.msedge.net
  • config.edge.skype.com
  • officeclient.microsoft.com
  • odc.officeapps.live.com
  • store.office.com
  • omextemplates.content.office.net
  • nexusrules.officeapps.live.com

Hope that helps!

Darren

Bernard_Huang
Contributor III

Thanks everyone for you help. But I am still no closer to a solution.

I have tried editing the host file with more and more URLs, but Excel, Word, and PowerPoint all wait for 2 minutes before it starts.
I think redirecting Microsoft connect back to local (127.0.0.1) isn't the answer. As long as it wants a connection, it will keep waiting for 2 mins. I have to stop it from even attempting to connect.

I think I'm just going to give up.

Josh_Smith
Contributor III

@huangbe My recommendation, having worked with an oppressive proxy server, is to add the URLs in Paul Bowden's document (that @cgolebio linked to) to your proxy configuration. If it wasn't clear Paul is the head of Office for Mac at Microsoft. He's also been very generous with his time and information, and if something in that document isn't correct we can engage with him on Slack to discuss/correct it.

There are undoubtedly multiple ways to implement this, work with your network gurus. You can have the traffic bypass the proxy, or pass through the proxy unauthenticated. Adding the URLs to the no-authentication list in the McAfee WebGateway proxy config is what allowed Office 2016 to work in our case.

If you can't get them to change the proxy....well I've been there too. It's 2016, we can't run Word from a floppy disk anymore. Modern operating systems and applications are going to access the internet, breaking them with a bad proxy configuration isn't security.

Bernard_Huang
Contributor III

Thanks @Josh.Smith ,

This makes a lot of sense. Thanks a lot.