Machine is not properly configured after enrollment

cnixon14
New Contributor III

Recently machines that are enrolled to JAMF are not receiving their configuration profiles or software that should be pushed to them after enrollment. The jamf command is not recognized in terminal and the computer is enrolled under its serial number rather than its computer name. Is there anything specific that could cause this? The computer downloads the MDM profile upon enrollment but nothing else.

8 REPLIES 8

snowfox
Contributor II

Are you using a QuickAdd package and which version of Jamf Pro?

snowfox
Contributor II

07e81b626bed4f149d6876473a4cd3cd

wildfrog
Contributor II

Thanks for posting that @snowfox. I just ran into that today with my AS machine. Since I’m new to user-initiated enrollment, what’s the purpose of the CA profile?

snowfox
Contributor II

The MDM profile gets installed first and a (CA) Certificate Authority certificate then gets installed. The CA certificate establishes the trust relationship between your Mac and the MDM server. It only happens either via Automated Device Enrolment or User Initated Enrolment. Without it your workstation won't communicate with the MDM server or trust it or anything that might download from it.

wildfrog
Contributor II

Interesting. Til now I’d enrolled with QuickAdd packages and it never installed a CA profile. Also, I’d used Mosyle in the past and their user-initiated enrollment just installed the MDM profile with no CA that I could see.

snowfox
Contributor II

When you click on the green word 'Verified' in the MDM profile on the Workstation, it will display the trusted certificate chain in a drop down window. The CA is not an actual listed config profile. The CA certificate is usually the root certificate in the chain and it is usually 'YourOrganisation JSS Built-in Certificate Authority'. Or it can be an external CA if you purchased and installed one on your Jamf Pro.

wildfrog
Contributor II

At least in Big Sur on my Apple Silicon MacBook Air, the CA Certificate does indeed show up as a User-level profile.
49131006f269488e8de22f7897327b29

cnixon14
New Contributor III

I am not using a Quick Add package just a log in screen and an assignment screen like these
ceadc5ca203d4a938f59043cb61f49c0

e4a34d08cccb41a68f64baf816b691c4