MacOS updates downloading but not applying

New Contributor III

We are trying to set up our Macs with a Software update policy from this link. I've set that up and deployed it to my test machine (M1 Mac running 11.2.1). I ran a 'sudo jamf policy' to kick it off and see what the process would look like. After the initial password to run the sudo command I was prompted again for my password and then it took awhile to I assume download the update (11.6). After downloading in terminal it says the update is complete and that it does not require a restart or a shutdown. However the update never installs, the Mac is still running 11.2.1, I rebooted the machine and it didn't apply any updates. Any thoughts on why its downloading but not installing?




Legendary Contributor III

Pretty sure this is due to the M1 Mac. It's not something that works via the command line softwareupdate method unfortunately. Only 2 valid ways to install OS updates on those models now is through the Software Update preference pane GUI or by sending an MDM command to the Mac to install updates. You can thank Apple for that. With each new OS and new Mac models Apple has made it harder and harder at every turn to get machines updated, for reasons that only they seem to know, because it sure doesn't make sense to anyone else.

Contributor III

Calling the softwareupdate binary (like this policy is doing) used to be reliable on older versions of the operating system, but became unreliable with the T2 chips and especially with M1.

You can try using MDM commands to update or look into something like nudge ( to try to prompt users to initiate the update, but I wouldn't rely entirely on the softwareupdate command for your updates


From my testing thus far, unless its a fluke, the MDM command from the GUI's management actions do not reliably work.


However, I have tested with the API and it works as expected, granted, it seems the user has little interaction/notification of the process

@beeboo , could you clarify a bit exactly what you are doing?  We've been having this same issue, of course (Apple talked about it in their last field SE update), and are looking for better ways around it than downloading the entire full installer every time we need to do an update (which Apple is making noises about not supporting anyway).  Thanks!

This is what has been tested to not really work (at least consistently)

Screen Shot 2021-09-21 at 10.14.42 AM.png

Im running the API call from my machine locally using this as an example and it seems to work effectively, there just isnt a lot or many notifications for the user i run the command at night.

Seems to go from start to finish in about an hour, on average.




New Contributor III

Well if I had just checked the ! next to the update server I would have gotten my answer....


Interesting! What version of Jamf Pro are you on? We're on v10.35 and I don't have a little 'I' icon beside the Software Update drop-down!

Also, I'm having the same issue with updates downloading but not installing on non-Apple Silicon machines, it worked fine last year with Catalina machines, but doesn't with Big Sur. Frustrating!


New Contributor II



I am a dork and i have no idea how to find cloud based JAMF Pro version i am on :(

Since things are not working for you how do YOU manage OS updates?

New Contributor II

Thanks for pointing this out!!!!


What exactly does this mean though? No updates will be installed by the policy on Apple silicone systems at all? Only some that do not require restart? Is the restart they talking about the Restart payload or restart backed into update itself? 


I found remote commands unreliable. Additionally how can you send a command that would just shut down system to reboot it without user interaction? This would lead to never ending complains and issues! Does this really mean only reliable way of doing OS updates is to download installer every time? 

New Contributor II

We are having this issue with intel macs issue as well. Seems to have been issue more recently our environment is MacOS Big Sur with both intel and M1.

Same here. Doing testing for Monterey updates right now and using Jamf's own instructions I get this error. It'll update things like Safari just fine, however it will not automatically install the OS update, only download it.

New Contributor II

I've come across this on serval instances on Jamf Pro now. I'm not certain exactly where the issues originates, but know a simple resolution.

The issues I've experienced were users would receive an OS Notification / Badge that software updates were available. Upon opening Software Update, no software updates were available to install.

Further investigation showed affected computers inventory the updates were available on the computers. By running jamf runSoftwareUpdate from terminal resolved the issue, the updates were then visible in Software Update to install.


  1. Create a Policy
  2. Add Files and Processes payload
  3. Browse to Execute Command field
  4. Enter jamf runSoftwareUpdate