MacOS updates installed, 5 mins force reboot

New Contributor II

Hi All,

Our Macs all reboot when a new MacOS patch comes out. We've had JAMF pro for over a year and I don't think this started till 10.14.1. Our users get a pop up saying 'Updates were installed and the system needs to reboot in 5 minutes'. Oddly enough my machine got the pop up and it didn't install the update.

After talking with JAMF support when this happened on 10.14.2 we added restart options to NOT reboot if a user was logged in. That apparently did nothing.

Any other suggestions?



New Contributor III

We are also looking for an answer to this one.

New Contributor

Ran into this issue with Mojave update that was released this week. Policy in place gives a 240 min delay but users were warned that they were going to have to reboot in only 5 mins.

Valued Contributor

@nategraham Do these happen to be newer Macs with the T2 chip? There was some chatter in the #mojave MacAdmin Slack about this when 10.14.3 was released. Apparently, if there is an update for BridgeOS on the chip it doesn't play well with restart commands or prompts following an update. Some users may even receive a message to fully shut down their Mac if you run softwareupdate -i -a vs just a restart.

There's a similar bug/quirk in the normal GUI, too. If you have a MBP with Touch Bar (T1 or T2 chip) and click "Download and Update" from System Preferences, the 10.14.3 update downloads, but there is no prompt to reboot. You have to manually click the Install/Update button again in System Preferences, and then the Notification Center alert appears saying an update will restart the Mac with a 60 second countdown.

New Contributor II

According to JAMF support, it's a known bug:
"PI-006540 Deploying a software update policy to a macOS computer reboots the computer even if "Do Not Restart" is selected from the Restart Options pop-up menu."

It's listed here as well:

New Contributor II

@sshort It's happening to all of our Macs, not just recent ones.

New Contributor

@sshort Also happening to us with older Macs (pre-T2) as well as new ones.

New Contributor II

We got that as well... Unfortunately it was at the exact same time as we pushed a corporate wide update policy that rebooted the entire company in the middle of the day...

Jamf support got a blast from us that day.

After all the investigations and back and forth with support they just eventually created the known issue article that you see above and called it a day.

I'd LOVE some update on that if anyone from Jamf is reading this. It's keeping me from executing the update policy I want and forcing all our updates to be manual which is a MASSIVE pain.

New Contributor III

Doesn't appear to be fixed in JSS 10.9.0. PI-006540 impacts us as well as we cannot keep our machines on the latest version without manual interaction.

New Contributor III

If you want to put in place a quick fix while this PI is solved, the problem is due to a LaunchDaemon that The JSS is not deleting after the restart.
Go to /Library/LaunchDaemons and delete the jamf reboot plist and that will fix the issue.
If it’s happening on a lot of machines you can create a script that deletes that file if it exists and stick it in a policy :)
Hope this helps!


I'm having this issue as well at my company

New Contributor III

@ricardtolosa Could you clarify which plist in /Library/LaunchDaemon ? Looks like there are five of them in there related to JamF.

New Contributor II

I have placed a 'softwareupdate' script in Self Service for my end users. We want to create an extension attribute that determines if there are any available software updates so we can create a smart group using that and narrow the scope down to just that group. Any thoughts?

New Contributor III

Hi @lmeinecke ,

The launch daemon name is this one: com.jamfsoftware.task.reboot.plist

Happened on several of our machines and the deletion of this plist + deleting the default reboot payloads from our policies have made the trick.

Let me know if you need any help :)

New Contributor II

And like clockwork, the monthly reboot cycle hit us again. Anyone else?

New Contributor II

Also, at least 2 of my users have rebooted 4 times.

New Contributor

Yep, us too. Very frustrating!

New Contributor II

Is there any update on this....?

New Contributor II

@ekrizon Doesn't seem like it. It's still on their active known issues list.

We've put in a script to defer updates for now. If it happens again I'm gonna get chased by a mob with pitchforks. It's a bummer, because now people are asking 'Is JAMF really worth it?'

New Contributor

Has there been any movement on this? We are seeing a similar issue, the 5 min reboot pops up, and reboots the mac outside of our reboot window.
We even have the reboot payload set to 60minutes, but it always gives a 5min.
this is not affecting all users, we have about 200 macs but only a couple users seeing this issue.

Contributor III

any updated on this problem? we're seeing users complain of "reboots every 5 minutes" now that 10.14.5 update is here.

New Contributor

Our team is also experiencing this issue, users machines are being rebooted and seeing a 5 minute warning message, even when no reboot payload is configured in a policy. We've configured an explicit "Do not restart" in our policy, but the behaviour remains.

Are there any updates on a resolution for this issue, or workaround?


New Contributor III

Hi @slyall, In order to fix the restart loop you need to delete com.jamfsoftware.task.reboot.plist from /Library/LaunchDaemons. Hope this helps until the issue is fixed :)

New Contributor III


My hosts that are impacted by this PI only have:


In their /Library/LaunchDaemons directory besides other non-JamF plists. I can't seem to find the one you reference with reboot in the filename.

New Contributor II

Looks like this issue has finally been solved in 10.14!

"[PI-006540] Fixed an issue that caused a computer to reboot when running Software Update even if "Do Not Restart" is selected from the Restart Options pop-up menu."

New Contributor II

Yeah, we got an email saying it was fixed....

All my users just the 5 minute pop up again on the 10.14.6 supplemental update from yesterday.

New Contributor II

Still seeing this issue. I can repeat it on my VM with the latest Apple Update. We need a fix for this ASAP.



New Contributor

We're seeing this with JPC on 10.15.5, deff not resolved as indicated above.

New Contributor III

Had this issue today. One of the bosses was about to go on a video call and that message popped up.
As a bandaid, I changed the client-side limitations so it cant check between 8am and 4pm. Looking for a fix.

Valued Contributor

You all should transition to a "forked" restart. This method utilizes a launch daemon to run the "jamf reboot" command. The use of a launch daemon is necessary so that the machine checks into Jamf after the daemon is loaded. If you simply ran the "jamf reboot" command, an inventory update would not have time to run to completion.

# Create
    echo > /tmp/ '#!/bin/bash

#Restart Computer with jamf reboot command
sudo /usr/local/bin/jamf reboot -minutes 1 -background && exit 0'

# Create and load a LaunchDaemon to fork restart

    echo "<?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">
    </plist>" > /tmp/restart.plist

    sudo chown root:wheel /tmp/restart.plist
    sudo chmod 755 /tmp/restart.plist
    sudo launchctl unload /tmp/restart.plist
    sudo launchctl load /tmp/restart.plist

exit 0

Simply change the minute flag in my "jamf reboot" command to customize when you want the machine to restart. Then create a policy with jamf helper message to notify the user before the launch daemon is placed.

New Contributor

I have exactly the same problem today. Just in 30 mins I got five pop-up windows "Updates were installed and the system needs to reboot in 5 minutes". If I click OK, my MacBook Pro (Catalina 10.15.7, 2019) will reboot in 5 mins. I have read through all the posts here, seems no solution. BTW, I only have three Jamf files:; com.jamfsoftware.jamf.daemon.plistl; and com.jamfsoftware.task.1.plist. Worked with Apple IT team today, no succeed in 40 mins.