Macs will not update to 12.6.2

Contributor III

Hello friends,

I am unable to get my Macs on 12.4 to update to 12.6.2. The update downloads, prepares to install, and the Macs restart but they are still on 12.4.

I have tried updating through sending a command via Jamf Pro, and manually via the System Preferences pane.

I have tried a Safe Boot.

I CAN get the Macs on 12.6.2 by reinstalling the OS in Recovery.

Anyone have any other suggestions?

Thank you.


Valued Contributor

I had seen that with VM's, but never with bare metal.

Contributor III

This fixed some of our Macs and able to update afterward. Hope this helps.

launchctl kickstart -k system/

Honored Contributor III

To ask the stupid question. How often do your devices reboot? Its possible for the daemons to hang.


What does the install.log say? I have seen plenty of one off issues where a device or two wont update, but never a feet unless it was a bunch of VMs. Maybe network traffic is getting filtered, but the logs should give an idea.

New Contributor II

I've had this issue with some of our mac's when the user that the update triggers on doesn't have Volume Ownership. 

I have switched us to using S.U.P.E.R.M.A.N by Kevin M. White because of this and providing admin credentials via [--local-account=AccountName] [--local-password=Password] options that has volume ownership.

This still requires the admin account to have a secure token/volume ownership.