Managed Apple ID Error

New Contributor

We have been setting up iPads for the last month with managed Apple IDs but came across an error today on multiple iPads. "Verification Failed, This service is not allowed for this Apple ID." We can't find anything unique about these iPads or IDs, the IDs were setup together through the SFTP with a bunch of other accounts that work correctly. Anyone seen this error, we are going to reach out to AppleCare tomorrow.



I've seen that error when trying to download an app with a Managed Apple ID, this link describes the restrictions for these IDs

Honored Contributor II
Honored Contributor II

I noticed a blog a few weeks ago noting that they can't be used in iTunes U as well.

If the error is randomly appearing, I'd assume there's an app or eBook that requires a full Apple ID to access.

Valued Contributor

What @davidacland said is correct. There is an issue with using iTunes U courses with managed apple IDs:

I believe this is how you can fix it:
1. Transferr the iTunes U course to a Managed Apple ID
2. Add teachers’ personal Apple IDs to iTunes U Public Site Manager
3. Invite those Apple IDs as contributors to the course.

New Contributor

We were getting the same error. When the ipads were updated to at least iOS 9.3.1, the apple ids worked. Now we're having another issue with downloading apps from self service but I don't know if it's related to the apple ids or the restrictions on the elementary ipads.