Minecraftedu (v.1.6.4) -Failure to Launch

bughollow
New Contributor III

I am trying to distribute Minecraftedu with a policy. I have successfully (?) created a .dmg using Composer. The file installs on the client computer, but will not launch for all users. The app relies on Java and the content is placed in the /users/library/Application Support.

It may be that the settings to fill home directories and user templates are not configured correctly in the .dmg?

The error in the Logs are not useful 'weird error: 13'

Does anyone have some tips/experience with this app? I tested placing the Application Support in a shared location with a direct installation. Again, the application will not launch for another network user (mobile account created on the Mac - OSX 10.9.x)

1 ACCEPTED SOLUTION

bughollow
New Contributor III

Okay, I figured it out!!! Once per User.

View solution in original post

6 REPLIES 6

bughollow
New Contributor III

Okay, I figured it out!!! Once per User.

View solution in original post

alindley
New Contributor

sahtudec what did you do to get this to work? I created a dmg and it looks like it installed correctly, but Im not sure if the path is correct. When I click on the Minecraftedu icon it just bounces in the dock, but doesnt open.

Mac OSX 10.7.5

bughollow
New Contributor III

My solution is not 'elegant', but it works.

I used the DMG that I created in Composer to install Minecraftedu. The Minecraft Launcher.app did not work. I found our that the path to the launcher is ~/Library/Application Support/minecraftedu/Launcher.jar (startlauncher.jar also works).

I used Automator to capture opening the file path on one account and saved it as an App. I tested it by copying it to the Applications folders on to a few computers using Remote Desktop. I named my file Launch Minecraft.app (next time I will name it Minecraft Launcher and possibly copy the icon and overwrite the App that doesn't work before Composing the package).

Anyway, my solutions worked for several users on the same laptop (mobile accounts only). I then packaged the App using composer (I did a capture, copied my App to the Applications Folder, and composed the package and saved as a dmg).

After it was working, I set a Policy under Files and Folders to delete /Applications/Minecraft Launcher.app

RobertHammen
Valued Contributor II

https://www.afp548.com/2013/12/05/deploying-minecraftedu/

bughollow
New Contributor III

I just did an update, still not elegant, but it works using Composer and successfully deployed to our student computers.

Steps:
1. I created 2 Applications using Automator - one to install Minecraft (the script from afp548 to copy the Minecraft folder from /Library/Application Support to the $User/Library/Application Support and one to launch Minecraft, again from the script on afp548
2. Copied the Applications to /Application on the machine used to Compose packages
3. Installed Minecraft in /Library/Application Support (in had to change permissions on the folder to perform the installation - I reversed them after the install). I also modified the launchersettings.ini file to open the game rather than the Launcher
4. Deployed the dmg via policy.

It takes about 15 seconds for the User to Install Minecraft from the Applications folder. I would have added the item to Self Service but putting it in the Applications folder is faster and easier for our students. It was also much easier for me - no plist or LaunchDaemon.

g1za
New Contributor III

@sahtudec

Trying to do this and not being one who is used to creating apps from automator, could you help me go through this please?

Or even better the pkg to deploy??

I've got my MinecraftEdu server and licences all done and working.