MS Office 2016 VL Serializer

CapU
Contributor III

Good Morning

We have the Office 2016 Volume license. I wanted to test the use of the VL Serializer pkg. I am unsure as to how the Serializer is supposed to work. When I install one of the office pkgs, then install the VL Serializer my Office apps are not active. Are my user supposed to "Activate" office even after installing VL Serializer?
I do have the Office 2016 Volume Installer but want to have all my bases covered.
What am I doing wrong?

Thanks

1 ACCEPTED SOLUTION

talkingmoose
Honored Contributor II

@CapU, AutoPkg downloads updates not full installers. To use the VL Serializer tool, you'll need to download and deploy a full installer.

I recommend you get the SKUless installer from http://macadmins.software. Install it and then install the VL Serializer. You'll have a fully up-to-date and licensed installation.

View solution in original post

18 REPLIES 18

andrew_nicholas
Valued Contributor

When you install the apps, are these repackaged versions of each individual app or just running only a non-serialized version with the old method of license file in place? From my experience the serializer does not perform a file deletion and does not overwrite an existing instance of the license, so you may need to repackage the tool to include this step.

CapU
Contributor III

These are versions of each individual app. The machine has not been licensed and never had Office installed.
Sorry I wasn't more clear.

mconners
Valued Contributor

When we used our volume license and serializer, we simply took the two packages and deployed via self service/auto install policy and everything worked. I believe the package for the serializer is the installer that places the appropriate serial number information into the correct places.

I did nothing special to get it to work, simply installed both onto our Macs.

We have the volume installer set as a priority of 10 and the VL serializer set as a priority of 18 to install after the volume installer is done.

andrew_nicholas
Valued Contributor

Are these individual files the package updates provided by MS? If so I don't know if they will work. In my experience it has been best to use the non serialized version to just update in place, and then if necessary delete any non needed applications after the fact.

CapU
Contributor III

b29ce541f058415aa97d264745273934
I have also downloaded updates using Autopkgr. If I was to just install Word that I downloaded then use the Serializer, when I open Word it asks to be Activated. I thought the whole purpose using the Serializer is to avoid that. I can't have my users Activating Office by themselves.

dgreening
Valued Contributor II

You should make sure that the serializer runs AFTER the Office package. Modify the package priority for the serializer to be after the Office package. Alphabetically speaking, the serializer would run first.

Also, keep in mind that the current serializer does not remove previously installed/copied licensingv2 files. If you need to remove that (you should) before re-serializing, you have to script its removal.

CapU
Contributor III

@dgreening On my test machine I FIRST install MS 2016 Word, and Excel. I then install the VL Serializer. Then I open up word and it asks to be activated. I don't understand.

I tested using Volume installer (15.19.1) then installed the updated pkgs (15.21.1). Seeing as I can't get the Serializer to work I'll just stick with that work flow.
And to be clear Office was never installed on my test machine.

sraveendran
New Contributor

@CapU If you installed the Volume Installer package from Microsoft VLSC then no need to run the Serializer package. You need it only if you are installing a Retail/Trial copy and you want to activate it.

CapU
Contributor III

I understand that I don't need to use the Serializer with the VLSC. What I don't get is why the serializer dosent "authenticate" my install that I downloaded using Autopkgr

talkingmoose
Honored Contributor II

@CapU, AutoPkg downloads updates not full installers. To use the VL Serializer tool, you'll need to download and deploy a full installer.

I recommend you get the SKUless installer from http://macadmins.software. Install it and then install the VL Serializer. You'll have a fully up-to-date and licensed installation.

View solution in original post

sraveendran
New Contributor

https://clburlison.com/demystify-office2016/ is a very good article to follow

mblair
New Contributor III

Is there anyone deploy this thru Casper Imaging successful?

I tried creating a .dmg and .pkg from Casper Composer and also use the original package from Microsoft still get an error to activate after imaging from Casper Imaging.

I can use a policy to use the VL Serializer after imaging but I have 400 computes that re-image every 3 or 4 months.

Any idea are welcome.

dgreening
Valued Contributor II

I deploy the SKUless Office 2016 365 package from macadmins.software and the VL Serializer (set to run AFTER the 2016 package) via Imaging without issue. Set both packages to install on the drive after reboot and TADA you have a serialized 2016 install.

MikeF
Contributor II

I have been making up packages for a while now using the directions on Rich Trouton's site

https://derflounder.wordpress.com/2016/01/14/creating-an-office-2016-15-18-0-installer/

They are for an earlier version but a couple changes to file names and this still works great.

endor-moon
Contributor II

Hi Folks, I've read a lot of threads on this and I don't believe I'm doing anything wrong, but the licensing doesn't seem to be working unless I manually run the VL Serializer on the target machine in the Finder. And oh yes, the OS image was created with the wonderful AutoDMG. Here is the post install log:

PostInstall 2017-04-20 08:45:00: Started postinstall script
Enroll 2017-04-20 08:45:00: Started enroll script
PostInstall 2017-04-20 08:45:00: Displaying lock screen
Enroll 2017-04-20 08:45:00: Checking for the lock file
Enroll 2017-04-20 08:45:00: Writing lock file
Enroll 2017-04-20 08:45:00: Setting computer name
Enroll 2017-04-20 08:45:02: Checking JSS connection
PostInstall 2017-04-20 08:45:12: Sleeping for 3 seconds
PostInstall 2017-04-20 08:45:15: Fixing ByHost files
PostInstall 2017-04-20 08:45:17: Creating user adminwithout an invitation
Enroll 2017-04-20 08:45:21: JSS connection is working
Enroll 2017-04-20 08:45:21: No invitation.
Enroll 2017-04-20 08:45:21: Doing trustJSS.
PostInstall 2017-04-20 08:45:21: Installing package AdminToolBoxMacLabs.pkg
Enroll 2017-04-20 08:45:22: Doing manage.
Enroll 2017-04-20 08:45:24: Doing recon.
PostInstall 2017-04-20 08:45:25: Installing package TypeClassicsSubset.pkg
Enroll 2017-04-20 08:45:25: Deleting Enroll directory and launch daemon for enroll, which also removes the lock file
PostInstall 2017-04-20 08:45:28: Installing package AdobeCC2017_Apr_7_Install.pkg.zip
PostInstall 2017-04-20 08:54:24: Installing package VirusBarrier.pkg
PostInstall 2017-04-20 08:54:31: Installing package Adobe Digital Editions 4.5.dmg
PostInstall 2017-04-20 08:54:37: Installing package Carbon Copy Cloner.pkg
PostInstall 2017-04-20 08:54:40: Installing package Casper Suite.pkg
PostInstall 2017-04-20 08:54:44: Installing package Crypt3.pkg
PostInstall 2017-04-20 08:54:48: Installing package Data Rescue 4.pkg
PostInstall 2017-04-20 08:54:51: Installing package DiskWarrior.pkg
PostInstall 2017-04-20 08:54:54: Installing package Firefox.pkg
PostInstall 2017-04-20 08:54:59: Installing package Google Chrome.pkg
PostInstall 2017-04-20 08:55:03: Installing package iBooks Author.pkg
PostInstall 2017-04-20 08:55:13: Installing package Microsoft Office 2016 15.33.17040900.pkg
PostInstall 2017-04-20 08:56:33: Installing package Thunderbird.pkg
PostInstall 2017-04-20 08:56:36: Installing package VirusBarrierX9-Settings.pkg
PostInstall 2017-04-20 08:56:42: Installing package VLC.pkg
PostInstall 2017-04-20 08:56:45: Installing package BBEdit.dmg
PostInstall 2017-04-20 08:56:50: Installing package Microsoft_Office_2016_VL_Serializer_2.0.pkg
PostInstall 2017-04-20 08:56:51: Deleting temporary user
PostInstall 2017-04-20 08:56:51: Removing postinstall directory and launch daemon
PostInstall 2017-04-20 08:56:51: Waiting for the enroll command to complete
PostInstall 2017-04-20 08:56:51: Done waiting
PostInstall 2017-04-20 08:56:51: Doing recon
PostInstall 2017-04-20 08:56:52: Deleting temporary user account
PostInstall 2017-04-20 08:56:54: Rebooting immediately

I am using Casper 9.98 running on CentOS 6.5 updated regularly with yum. The distribution point is a simple SMB share hosted by one of our Ubuntu servers running Samba 4. The NetBoot server is an iMac 5K running Sierra. Casper's NetBoot was created by AutoCasperNBI.

I've been fiddling around with this for a while. One thing that seems prevalent during imaging is the dreaded device signature error. Our JSS has a self-signed certificate but it doesn't expire for some time. Although looking at the log below I don't see that error this time around.

For the sake of completeness, here is the imaging log of my test on a new MacBook Pro 15-inch with TouchBar:

Initializing Imaging Process...
Mounting smb://animation.**********.ca/casper...
Preparing disk for block copy...
Performing Block Copy of osx_updated_170330-10.11.6-15G31.hfs.dmg...
Cleaning up after block copy...
Setting computer name to "XYZMaster"...
Creating /private/etc/jamf.conf...
Creating /usr/local/bin/jamf...
Creating jamfHelper...
Ensuring Apple's Setup Assistant does not appear...
Creating First Run Enroll Script...
Creating First Run Post Install Script...
Adding line to Fix ByHost Files...
Adding line to Create user admin...
Adding line for installing AdminToolBoxMacLabs.pkg...
Adding line for installing TypeClassicsSubset.pkg...
Adding line for installing AdobeCC2017_Apr_7_Install.pkg.zip...
Adding line for installing VirusBarrier.pkg...
Adding line for installing Adobe Digital Editions 4.5.dmg...
Adding line for installing Carbon Copy Cloner.pkg...
Adding line for installing Casper Suite.pkg...
Adding line for installing Crypt3.pkg...
Adding line for installing Data Rescue 4.pkg...
Adding line for installing DiskWarrior.pkg...
Adding line for installing Firefox.pkg...
Adding line for installing Google Chrome.pkg...
Adding line for installing iBooks Author.pkg...
Adding line for installing Microsoft Office 2016 15.33.17040900.pkg...
Adding line for installing Thunderbird.pkg...
Adding line for installing VirusBarrierX9-Settings.pkg...
Adding line for installing VLC.pkg...
Adding line for installing BBEdit.dmg...
Adding line for installing Microsoft_Office_2016_VL_Serializer_2.0.pkg...
Copying AdminToolBoxMacLabs.pkg to FirstRun...
Copying TypeClassicsSubset.pkg to FirstRun...
Copying AdobeCC2017_Apr_7_Install.pkg.zip to FirstRun...
Copying VirusBarrier.pkg to FirstRun...
Copying Adobe Digital Editions 4.5.dmg to FirstRun...
Copying Carbon Copy Cloner.pkg to FirstRun...
Copying Casper Suite.pkg to FirstRun...
Copying Crypt3.pkg to FirstRun...
Copying Data Rescue 4.pkg to FirstRun...
Copying DiskWarrior.pkg to FirstRun...
Copying Firefox.pkg to FirstRun...
Copying Google Chrome.pkg to FirstRun...
Copying iBooks Author.pkg to FirstRun...
Copying Microsoft Office 2016 15.33.17040900.pkg to FirstRun...
Copying Thunderbird.pkg to FirstRun...
Copying VirusBarrierX9-Settings.pkg to FirstRun...
Copying VLC.pkg to FirstRun...
Copying BBEdit.dmg to FirstRun...
Copying Microsoft_Office_2016_VL_Serializer_2.0.pkg to FirstRun...
Ensuring system files are hidden...
Unmounting Distribution Point...
Blessing System...``

Leal
New Contributor III

@endor-moon The way I got it working was by running the office installer right after the OS image completes then running the serializer post the image process, you'll need to set that last part in the actually package.

j_grafton
New Contributor III

Sorry I feel like I am missing something. When I get the ISO serialiser from the microsoft website how do i compose the file into something jamf can read. When I make a pkg it doesn't work when I run it on a mac
if i run the iso file manually it works but not after compose it using composer
thanks

sdagley
Honored Contributor II

@j.grafton The .iso you get form MS is a disk image. Mount that disk image on your Mac, and you'll see one of the files it contains is Serializer .pkg. Upload that .pkg to your DP and deploy it via a Policy with the Office installer .pkg.