name: /usr/sbin/system_profiler

New Contributor III

What would make Casper show "/usr/sbin/system_profiler" under both model and serial number for a computer? The machine appears to be named correctly.


Valued Contributor

I see the same thing.

I'd guess that those are 10.8 machines and your running a version of JSS that is not 10.8 aware (less than 8.6 I believe).

Honored Contributor

Hi Everyone,

Has this Mac had hardware level repairs recently? I have seen system profile return non standard output back to the JSS after a hardware repair like a main logic board, and the firmware was not flashed to contain the serial number.

I am not sure exactly how the binary pulls that info, but here is a test using the system_profiler binary on my system:

bash-3.2# system_profiler SPHardwareDataType | awk '/Serial Number/ { print $4 }'

I redacted my serial number and put a false one in, but it worked for me. You can also inspect the System Profiler app to see what is also displays. I suspect it is reported wrong in the OS and this is why you are seeing that. If this is not the case please contact your account manager.


We have seen this issue a few times. Typically the culprit is inventorying the machine with an older version of the Recon Application. On the machine that is showing /usr/sbin/system_profiler, try re-enrolling that machine with the Recon Application or the command line by typing "sudo jamf enroll". Hopefully this helps.


New Contributor III

Good one, Joel - you hit the nail on the head. I tried a "sudo jamf enroll", which failed with an unrecognized command error. That was enough to confirm the older version of Recon scenario. I attempted a command line recon, which also failed, so I deleted the machine from the JSS then enrolled again with Quickadd. Happy with that.