NetSUS Catalina

Contributor II

Is anyone able to deploy Apple Updates to Catalina from NetSUS 5.0.1? I'm getting the following error on a number of clients (10.15.1). NSURLErrorDomain error -1012

10.14 and older are updating as expected.

I'm setting the update server via a Configuration Profile and this is deployed to all clients, all MacOS versions.




Thank you!


New Contributor III

@ubcoit The custom URL paths do not work with macOS Catalina 10.15 as they did in 10.14 and prior. Have you tried applying a direct URL/catalog path for Catalina? Using your example:

I hope this helps!

Contributor II

Thanks for the reply John.

I created a fresh configuration profile with your proposed changed URL and excluded a test MacBook from our standard configuration profile. Verified that the profile applied and the URL was updated. Same result as before. I verified as well that the suggested URL works in a web browser on the suspect MacBook.

Any other thoughts?

Thanks again!

New Contributor II

We applied the NetSUS 5.0.1 update but were still having issues applying 10.15 updates. We discovered the updated version of Darwin and catalog were not added to the .htaccess file.

The fix was to append /srv/SUS/html/content/catalogs/.htaccess with the following

RewriteCond %{HTTP_USER_AGENT} Darwin/19
RewriteRule ^index(.*).sucatalog$ others/index-10.15-10.14-10.13-10.12-10.11-10.10-10.9-mountainlion-lion-snowleopard-leopard.merged-1$1.sucatalog [L]

Contributor II

Thanks for the reply bloree.

I checked the .htaccess file and it was missing those lines which I've added. Note above, I believe you are missing a before the .sucatalog$ (At least all the other ones in my .htaccess log have the ).

This changed hasn't solved the problem. Stopped and started NetSUS, rebooted the client.

I also tried again with my original URL and John's suggested URL and still no go after the .htaccess change.

I'm preparing another workstation to start clean with this problem (not an existing in use workstation).

Thanks again for the suggestions.


@ubcoit I'm having the same issue here, have you got any solution yet?

Contributor II

@Dalmatian The .htaccess fix as suggested by @bloree did fix it for me in the end. I would suggest double checking your certificates as well as recently Gandi expired some certs which caused some issues for us (May 30).

Good luck!

New Contributor

After updating the .htaccess files I still was unable to access updates via Catalina. What did work was replacing with Even though this worked, its seems like going backwards. Is this also what everyone had to do?