New MacBook Air 7,1 came with flash storage and PCI-Express


And the JSS (v9.72) doesn't see the drive! It also doesn't show it as having "Disk Encryption", yet it does. I had to FIleVault to because PGP would fail when trying to provision the drive. I've 15 other MBAs of 7,1 or 7,2 and none of them have this issue, and all of them show normal storage attached as PCI. Some of them have come in AFTER this one, but the Apple site does say that PCIe & Flash Storage is what we'll get. Here's what the MBA 7,1 shows for storage (prior to FIleVaulting):



      Available: 103.27 GB (103,267,995,648 bytes)
      Capacity: 120.01 GB (120,007,426,048 bytes)
      Mount Point: /
      File System: Journaled HFS+
      Writable: Yes
      Ignore Ownership: No
      BSD Name: disk1
      Volume UUID: A11D4890-2222-3015-BBD8-<snipped>
      Logical Volume:
          Revertible: Yes (unlock and decryption required)
          Encrypted: Yes
          Encryption Type: AES-XTS
          Locked: No
          Conversion State: Complete
          Bytes Converted: 119.35 GB (119,348,527,104 bytes)
          LV UUID: BD53F189-9CF2-42BE-BDB3-<snipped>
      Logical Volume Group:
          Name: <snipped>
          Size: 120.37 GB (120,368,205,824 bytes)
          Free Space: 70 KB (69,632 bytes)
          LVG UUID: ED7F4988-6B9B-42F1-9319-<snipped>
      Physical Volumes:
          Media Name: APPLE SSD AP0128H Media
          Size: 120.37 GB (120,368,205,824 bytes)
          Medium Type: SSD
          Protocol: PCI-Express
          Internal: Yes
          Partition Map Type: GPT (GUID Partition Table)
          Status: Online
          S.M.A.R.T. Status: Not Supported
          PV UUID: 0564E2E5-5DF7-4441-B80D-<snipped>


Anyone else seeing this?
I'm guessing we'll see it more and more, especially when the USB-C MBs come in.
As a side note, I ran AHTs & ASDs on it and it passed everything.


Contributor II

You don't say what version of JSS you are running..
That info might be significant.. for this 'latest Apple hardware'


Latest... 9.72

I opened a support ticket with JAMF over this.


We have the 7,2MacBook Air and we do not have this issue. If FileFault 2 is removed does it show the drive?

Valued Contributor II

We also have the 7,2 Air and are not seeing this with FileVault2 enabled.

Contributor III

FWIW I've recently come across a few portables that just were just not right from the get-go. Odd & random behavior was all there was. In each case the units wouldn't boot into Apple Diagnostics so they were sent back and replaced.

It might be worth a shot to see what Apple Diagnostics does or reveals.



No.. We've tried all variations of 10.10.2 through latest full patching.
We've tried vanilla OS X, none of our customizations and not enrolled in Casper.

Always the same behavior with PGP, and when enrolled in Casper, the same oddly missing info in Storage section of the JSS for the computer object.



So, I did do that because I feared (initially) that it was a hardware problem. Strangely, this device behaved unlike any other Mac I've ever see using the Apple Service Toolkit. It was fully and ONLY AST2 and required that I log into a website to detail the tests I wanted to do, and then it would run on the Mac, rinse repeat. It passed 'all the things', but this was very odd AST behavior.

EDIT: And my AST(s) are fully up to date.. at least of the last time I was able to get into GSX (don't ask).

Contributor III

I'm seeing the same thing on 2015 MacBooks.


New Contributor III

I second the MacBook statement. MacBook 8,1 My JSS does not show any storage on this machine.
ARD does report the hard drive size so they made a change in the latest version to read these drives.af866cd894bf4ad698b7ecc363e6baa8

New Contributor II

Thirded (?) on the MacBook - we have new 2015 MacBooks with the same issue: 0 drives in storage. We've put in a ticket as well.

We do not see this on our newer Airs - ours still seem to be sata at the moment

New Contributor

Seeing the same issue with a 2015 MacBook. Just opened a support ticket.

Valued Contributor II

MacBook Pro 15" Mid-2015 are showing up ok for me in the JSS 9.72.
MacBook 12" Early-2015 checks out fine as well under JSS 9.72

New Contributor II

I wonder if these drives are using NVMe and the 'Storage' item relies on AHCI

New Contributor

New MacBook 2015 and I am having the same issue. Although, I also have a MacBookAir7,1 that is displaying same error. Both using PCI express and have SMART status listed as Not supported. We have not upgraded our JSS either, so if someone can confirm a resolution on this issue that would be great :) I will post as soon as I fix.


The "no disk" thing is fixed in updated versions of the JSS.