Newest Adobe CC Applications System Requirements Change

ttyler1999
Contributor

So after seeing that there were new versions of the Adobe CC apps, I began to download and package them for distribution. However, every time I tried to install them on our machines I got a failure error.

It turns out that the requirements for CC apps has changed and they now require macOS 10.11 or above. Since we are still at 10.10 the installation failed.

https://helpx.adobe.com/creative-cloud/system-requirements.html

Just an FYI so you don't waste a day like I did! πŸ˜‰

2 REPLIES 2

aminer
New Contributor

Why not just update your Mac OS? A lot of new software will require a later OS version.

ttyler1999
Contributor

As we are a small 2 man shop, we don't normally update our OS over the 3 year lease of our equipment. Since our lease is up this spring and we will be getting all new laptops preinstalled with 10.13, we will be fine going forward.