Office 14.5.0 update resurrects invisible main window issue

cdev
Contributor II

Those of you who were participating in the developer releases or public beta of Yosemite (or even the dot zero release) may recall that there was an issue with Outlook 2011 not displaying the main window if you had the disclosure triangle open to show your list of folders in your mailbox. Sad to say, the Office 2011 14.5.0 update has resurrected this issue. Outlook will launch, but the main window will not open. You can create new messages and events via the menus, but that's it. If you keep that disclosure triangle closed when you quit the application, it'll launch just fine again.

1 ACCEPTED SOLUTION

joecurrin
New Contributor III

14.5.1 just released to fix this issue. https://support.microsoft.com/en-us/kb/3048688

View solution in original post

74 REPLIES 74

scottb
Honored Contributor

@cdev,

Yes, this is confirmed x3 by me and teammates on 10.10.4 seed#3.
Went back to 14.4.9 and all is well.

jwojda
Valued Contributor II

any way to block the update?

nessts
Valued Contributor II

sent in to apple feedback tool this morning. reminded them that they broke and fixed this once already.

nessts
Valued Contributor II

@jwojda I think this is only a problem for 10.10.4 beta people. my 10.10.3 box is running 14.5.0 just fine. restarts with disclosure triangles open or closed.

mm2270
Legendary Contributor III
any way to block the update?

Not exactly. Its a regular pkg install, so Restricted Software won't help. Maybe get your network/firewall folks to temporarily block the MS Auto Update site and mactopia.com since they would be available from those locations. Other than that, can't really think of a way to block it.

We'll likely get a notification out through official channels to our user base to not install this update, 'cause you know many of them just will.

Edit: misunderstood the extent of this issue. If its just for folks running 10.10.4 beta, I'm not very concerned.

scottb
Honored Contributor

I'm installing on 10.10.3 Macs now to double-check. Sent in feedback as well so hoping it's dealt with in the next build.

KPat
New Contributor

I'm running 10.10.3, just installed the Office 14.5.0 update and the main window doesn't show, so it's not limited to 10.10.4 beta apparently.

Is there any kind of work around while the fix is worked on?

rtrouton
Valued Contributor III

Here's the process I just sent to my folks:

  1. Quitting all Office applications
  2. Uninstall Office 2011 - see here for the procedure: http://www.officeformachelp.com/2012/12/office-for-mac-2011-remove-office/ (see the "USE SCRIPT TO REMOVE" section.)
  3. Restart the Mac
  4. Reinstall Office 14.4.9 following the restart.

Outlook should start working again once rolled back to 14.4.9.

mark_mahabir
Valued Contributor

It's currently being discussed here and here

I was able to reproduce the issue this morning on 10.10.3 but got back up and running again by killing the existing identity and having a new one created on next launch.

scottb
Honored Contributor

New Identity did not help on my 10.10.4 Macs. I'm just sticking with 14.4.9 for now and recommending others do as well...
Pretty much did what Rich did above.

davidacland
Honored Contributor II
Honored Contributor II

Not sure what I'm doing wrong (or right :/ ) but I can't reproduce the fault. I've got 10.10.3 and 14.5.0.

nessts
Valued Contributor II

quit outlook
kill database daemon if its still running, which it likely is on this version
delete Library/Caches/Outlook and com.microsoft.outlook
delete Library/Preferences/com.microsoft.Outlook.plist and com.microsoft.outlook*
killall cfprefsd
relaunch outlook
new window will appear

jwojda
Valued Contributor II

is this only on upgrades or are new installs affected?

scottb
Honored Contributor

@jwojda , don't know if anyone has a full 14.5.0 installer, but I did my updates on three 14.4.9 installs and one 14.4.8.
Cleanly imaged Macs, FWIW sans my own Mac, which is the only one that had a prior Outlook Profile. The others did not have a profile yet.

jwojda
Valued Contributor II

@rtrouton

Here's the process I just sent to my folks: Quitting all Office applications Uninstall Office 2011 - see here for the procedure: http://www.officeformachelp.com/2012/12/office-for-mac-2011-remove-office/ (see the "USE SCRIPT TO REMOVE" section.) Restart the Mac Reinstall Office 14.4.9 following the restart. Outlook should start working again once rolled back to 14.4.9.

I noticed the script doesn't remove the Office 2011 folder, but none of the apps launch, even after reboot.

duncan_wright
New Contributor II

We have seen this issue on a pretty widespread basis. Not every system is affected, but a significant nubmer are. My system (10.10.3/14.5.0) is not affected, but many with the same OS/Office version are affected.

Deleting or moving preferences and deleting cache/killing cfprefsd fixes the issue, but in many cases it will occur again within a couple of hours.

Our best solution at this point mirrors Rich's - remove office 2011 14.5.0 via script, reinstall 14.4.9 (luckily we did not update our Self Service installer yet).

jwojda
Valued Contributor II

@boettchs sorry, yes, that's what I meant a clean install (new deployment/reimage via whatever office 2011 installer + 14.5.0 update) vs upgrading a user's install.

scottb
Honored Contributor

@jwojda ,

If you want to block what I'd guess would be most users from updating, put "Microsoft AutoUpdate.app" into restricted software.
There may well be some geeks that look for updates, but that I'd wager this would stop most.

Library/Application Support/Microsoft/MAU2.0/Microsoft AutoUpdate.app

stevehillnz
New Contributor III

Removing the preferences and killing the cfprefsd processes is a temporary fix, and the problem can return on relaunch. Testing here indicates that the problem occurs when you expand the Exchange mailbox sub folders then quit with them expanded.

As a quick fix, without the need for uninstalling, we have been simply replacing the Microsoft Office 2011 folder with one copied from a machine running v14.4.9. We have had 100% success with this so far.

cdev
Contributor II
the problem occurs when you expand the Exchange mailbox sub folders then quit with them expanded.

Hit the nail on the head. This issue was introduced by some change in Yosemite, and Microsoft released a patch to fix it (I think it was 14.4.6). I've reverted to 14.4.9 and all is well. Hopefully we'll see some quick action on this one.

AVmcclint
Honored Contributor

I can confirm the problem here too. Running 10.10.3. I updated and experienced the problem. I completely uninstalled Office and deleted prefs and reinstalled and updated to 14.4.9 and all was well again. I updated again to 14.5.0 on the off chance it was just a funky installation but the update killed Outlook again. I uninstalled, reinstalled and updated back to 14.4.9 and left it as that. I have AutoUpdate disabled on all the Macs here and I control what is either pushed out or made available via SelfService. 14.5.0 is one that will NOT be made available here. I'll wait for 14.5.1. I have not tried it on 10.9 Macs.

CasperSally
Valued Contributor II

another thread on this here

dgreening
Valued Contributor II

We have blocked MS AutoUpdate from running using Restricted Software, and used the message to point people to Self Service for approved MS updates. We had already set the check to Manual via a defaults write. Hopefully this gets sorted shortly.

emily
Valued Contributor III
Valued Contributor III

I just had a user walk up with this happening on his Mac. 10.10.3. Fun!

asegura
Contributor

@dgreening care to share a screenshot of your restricted software for that. I tried to get it setup but had no luck. Also does anyone have an extension attribute that shows the MAC's that have MS Autoupdate set to automatic?

mm2270
Legendary Contributor III

The MS Auto Update setting is user specific, so it lives in the ~/Library/Preferences/com.microsoft.autoupdate2.plist, unless you are already managing it with something like Managed Preferences or a Config Profile in which case that should be overriden by your setting.

#!/bin/sh

echo "<result>$(defaults read /Users/$(ls -l /dev/console | awk '{print $3}')/Library/Preferences/com.microsoft.autoupdate2.plist HowToCheck)</result>"

It will list "Manual" when its not set to auto check for updates. I forget how it shows up when its set to auto, maybe "Auto"? You can also pull the last update check date from the plist (LastUpdate) as well as a key called "WhenToCheck' but I'm not clear what that one does. Anyone know? Mine is set to "2" whatever that means.

asegura
Contributor

If its set to automatically this would be the result HowToCheck = Automatic;

asegura
Contributor

@mm2270 that worked perfectly. I need to create a configuration profile to set it to manual. I know how to do it via a defaults write.

scottb
Honored Contributor

@asegura

This is how it's setup - works great, took 30 seconds to do. Just as easy to undo when the time comes.

33550cf5fb7f4395a1c36f9703ff56f8

Message:

d8f00695293f486c960ccf8fa7b39575

andrew_nicholas
Valued Contributor

@nessts Your fix worked for me! Just to be safe though, I also put in a block like @dgreening suggested.

dgreening
Valued Contributor II

Anyone notice that even when MS AutoUpdate is set to Manual in ~/Library/Preferences/com.microsoft.autoupdate2.plist, when you open any of the Office Apps when the Restricted Software for MS AutoUpdate is in place it quacks the restricted message at you? Shouldn't AutoUpdate not even start up if its set to manual?

scottb
Honored Contributor

@dgreening

Yes. So I turned off the message...annoying. Again.

mm2270
Legendary Contributor III

@dgreening Yes! I recall running into that exact scenario about a year or more back. I'd completely forgotten about that though. We tried adding MS Auto Update.app into Restricted Software, but unfortunately it seems that the application tries to open or is accessed in some way in the background on launch of other Office applications, so the Restricted Software message was popping up for us even though it wasn't specifically launched. We had to quickly shut off the Restricted Software setting to avoid annoying everyone and incurring some wrath.

I wish I had an answer for how to get around that, but the only thing I can suggest is to not make it come up with a message. Just kill it silently and no message. It will still stop it from running, but its going to kick in on every Office application launch - so annoying!
You 'd also want to make sure NOT to check to send emails on violations, unless you like getting spammed by your JSS!

jhalvorson
Valued Contributor

I learned the hard way too about how often that process is opened. @boettchs @dgreening I enabled the same software restriction process name "Microsoft AutoUpdate.app", along with a message to the user informing them to "don't update to 14.5.0..." and scoped it to devices with 10.10.

Turns out the warning message was posted over the lock screen saver and multiple times to the end users. That resulted in extra calls to the help desk. Now I just have it quit the app and the message field is blank.

scottb
Honored Contributor

Just turn off the message. It's fine now...
Or rather, take the text out of the message portion of the Restriction setup.

dgreening
Valued Contributor II

Yeah, it looks like that is what I am going to have to do. Can annoy the crap out of our users, thats for sure!

mm2270
Legendary Contributor III

I just put this Config Profile together using mcxToProfile. I tested it installing it as computer level:
sudo profiles -I -F /path/to/MSAutoUpdateSettings.mobileconfig
and it seems to work. It forces the Microsoft Auto Update.app settings to "Manual" You can click the "Automatic" radio button in the app, but if you quit and relaunch it, its set back to "Manual" so it forces the setting. Use at your own risk as I haven't thoroughly tested it, but I did install it as I mentioned on a 10.10.3 Mac. I don't use mcxToProfile that often so hopefully it converted everything over and didn't add in anything that shouldn't be there.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>PayloadContent</key>
    <array>
        <dict>
            <key>PayloadContent</key>
            <dict>
                <key>com.microsoft.autoupdate2</key>
                <dict>
                    <key>Forced</key>
                    <array>
                        <dict>
                            <key>mcx_preference_settings</key>
                            <dict>
                                <key>HowToCheck</key>
                                <string>Manual</string>
                            </dict>
                        </dict>
                    </array>
                </dict>
            </dict>
            <key>PayloadEnabled</key>
            <true/>
            <key>PayloadIdentifier</key>
            <string>MCXToProfile.f47d5b57-53d3-4488-a13f-83bd703cfdea.alacarte.customsettings.1c7fafc2-3dc1-4320-ab7b-2e0c4fced0b9</string>
            <key>PayloadType</key>
            <string>com.apple.ManagedClient.preferences</string>
            <key>PayloadUUID</key>
            <string>1c7fafc2-3dc1-4320-ab7b-2e0c4fced0b9</string>
            <key>PayloadVersion</key>
            <integer>1</integer>
        </dict>
    </array>
    <key>PayloadDescription</key>
    <string>Included custom settings:
com.microsoft.autoupdate2
</string>
    <key>PayloadDisplayName</key>
    <string>MCXToProfile: com.microsoft.autoupdate2</string>
    <key>PayloadIdentifier</key>
    <string>MSAutoUpdateSettings</string>
    <key>PayloadOrganization</key>
    <string></string>
    <key>PayloadRemovalDisallowed</key>
    <true/>
    <key>PayloadScope</key>
    <string>System</string>
    <key>PayloadType</key>
    <string>Configuration</string>
    <key>PayloadUUID</key>
    <string>f47d5b57-53d3-4488-a13f-83bd703cfdea</string>
    <key>PayloadVersion</key>
    <integer>1</integer>
</dict>
</plist>

dstranathan
Valued Contributor II

Looks like MS still has the 14.5.0 update available online.

https://www.microsoft.com/en-us/download/details.aspx?id=46973
https://support.microsoft.com/en-us/kb/3062536/

Im going to open a support ticket and verify that MS knows the extent of these issues.

themacallan
New Contributor III

Rather than uninstalling Microsoft Office 2011 and rolling back to 14.4.9, we've been encouraging affected users (less than 1% of our population fortunately) to use Self Service to fix Outlook as needed until a patch becomes available.

Maybe your environment would welcome that, maybe not. Regardless here is the script based off the commands provided by @nessts. You may notice that I don't use $3 for the username. This script is technically agnostic and can be run as root through ARD to fix the user who is logged in to increase your killing power.

I've also included a handy icon for Self Service.

Script: http://tinyurl.com/nro5nhn
Icon: 03b1bcde2d384368be39fde4ca53df7a