Office is Failing Install

New Contributor

Our Self Service Office Install for Mac has worked all year until recently. Now it fails every time. This is what I get from from the logs:

[STEP 1 of 5]
Executing Policy MS Office Install
[STEP 2 of 5]
Downloading Microsoft_Office_2016_15.29.16120900_Volume_Installer.pkg...
Verifying package integrity...
Installing MS Office Installer...
Installation failed. The installer reported:
[STEP 3 of 5]
Downloading Microsoft_Office_2016_VL_Serializer_2.0.pkg...
Verifying package integrity...
Installing Microsoft_Office_2016_VL_Serializer_2.0.pkg...
Successfully installed Microsoft_Office_2016_VL_Serializer_2.0.pkg.
[STEP 4 of 5]
[STEP 5 of 5]

I have no idea where to go from here...

Thank you!



Have you checked the install.log in /var/log on the affected machines?

New Contributor

I'll have to try on another machine tomorrow. The var/log/installer.log didn't provide much information - it said that there was a folder that was missing. I didn't have much time to investigate as the teacher needed to run.

I'll see what I can get tomorrow after more testing.

New Contributor

Open Casper Admin, double click your Microsoft_Office_2016_15.29.16120900_Volume_Installer.pkg, click "Options", and check "Install on boot drive after imaging". Do the same thing with your serializer. Additionally, in my deployment profile, I set the Office serializer to cache rather than install, and under the maintenance section of the profile, I checked the "Install cached packages" so that it runs last. It worked for me. Hopefully this works for you.

New Contributor

What about through Self Service? That's what I really hope to have working.

New Contributor

Our server uses the same package for both imaging and for self service. I have a much more complicated policy with a script that...
1. executes bash script that kills all MS processes and removes all Office 2011 components (sans-outlook database) from whomever's Mac that initiates it in Self Service.
2. caches the VL serializer
3. Installs Office 2016
4. removes 2011 dock items, replacing them with 2016 versions
5. installs the cached serializer
6. issues a bash command that removes the flawed that breaks user-initiated Microsoft updates.

I wrote my own 2011 removal script. The scoped user clicks once and the whole process happens automagically.

Whether or not it's issued from Self Service... it was discovered that checking that box in the package options yields a much greater degree of success with Office 2016. I can't explain why? I think I read it on MacMule's write-up?

New Contributor III

I am having the same problem with the latest Office update. Doesn't matter if I use SS or if I call the policy from terminal. Nothing in the log, just says result of command is .... and it is blank.

If I install the package locally not using JAMF, it works fine. Very frustrating.