OT: Open Directory issues

New Contributor

Hey Guys i know this is OFF topic but I'm struggling here.. Created Open directory master from archive, all is well everyone can authenticate..but tried creating a replica and Keep getting this strange error and behaviors.. When trying to set up on replica...i get the following error

An error occurred while configuring slave as a directory replica. Please check your network configuration and try again...

However, whats strange is on the master...i see the replica.....????? And if i do it more than once it shows up more than once......but never on the replica...

Any ideas would be greatly appreciated. PLEASE


New Contributor II

I ran into a similar issue while we were still using Open Directory. The issue that we encountered was that there was already a record of the replica in Open Directory, and Open Directory was actually creating a duplicate entry within LDAP.

You could try searching LDAP through the command line for any duplicate computer records. Looking through my notes, I think that this will output any duplicate computer records.

for user in ldapsearch -x -h localhost -b cn=computers,dc=testodm,dc=testserver,dc=com dn -E pr=1000 | grep "^dn: cn=" | sed -e 's/dn: cn=//' -e 's/,.*$//'; do echo -n "$user: "; sudo ldapsearch -x -H ldapi://%2Fvar%2Frun%2Fldapi -b cn=users,cn=authdata "(uid=$user)" | grep -c "^dn" ; done | tee -a ~/Desktop/dupcomputers.txt

Your DC information will be different than what is in the command.

Are the errors that you are seeing on the replica or the master? You may also want to tail the logs on the replica while creating it to see if there are any specific errors in there that might point to the issue.