Parallels Desktop 18 - Unable to install due to Apple malicious software check

New Contributor II

Good day all,

A little background: I had Parallels Desktop 17 deployed for a few months with no issues installing it on many client's machines. Suddenly about 2 weeks ago it failed to install on any new machines. I kept getting an error messaging when installing that said "Parallels" can't be opened because Apple cannot check it for malicious software. 

Now I know how to get this working on a per machine basis if I install it manually but how would I give the app permission to install via Jamf? I tried setting Gatekeeper to allow App store apps and trusted developers but this did not change anything.

Any advice?


Valued Contributor II

The app was probably uploaded to your distribution point with the quarantine flag still set. You can either open the installer on your machine, get past that "this was downloaded from the internet" prompt and then re-upload the installer or you can run xattr in a terminal window to clear the flag and then re-upload it. Rich Trouton explains this in detail on this site here

Thanks for your reply. So I actually tried that but it did not have any
affect. I am going to try repackaging the app.


Valued Contributor

Are you manually repackaging the application or using their Autodeploy tool

Honored Contributor II

The applications notarization and or signature is bad. Download a new copy of 17 and see if it works. If it still does not work reach out to parallels. I would not bother trying to force gatekeeper to allow things as that is just a symptom and a vulnerability finding waiting to happen, fix the problem.