Problems Packaging MS Office 2011 SP1

Not applicable

Has anyone tried to package up the recently released (2 or 3 days ago) Service Pack 1 for Microsoft Office 2011? I cannot get a working package created using standard Composer methods.


1) Using Casper Suite 8.0
2) Packaging against a clean 10.6.4 OS image with only the initial base MS Office 2011 installed
3) Downloaded Service Pack 1 .dmg from MS website – the .dmg contains an installer
4) Using Composer 8.0 – Normal Snapshot method


After running Composer snapshot of pre-install environment, install of Service Pack 1 for MS Office 2011 proceeds normally. Post snapshot package creation runs normally, but when I review the list of difference files created by Composer, I find that each of the MS Office 2011 application files is grayed out in the /Applications folder, with the prohibitory sign over the app icon. The Contents files within the apps appear to be fine. Other difference files in the /Library folder appear fine.

I've never seen this happen before. I've tried applying the /Application folder permissions to everything inside, but no luck.

Thoughts, anyone?

Jeff Elliott
Tech Support Specialist
Hempfield School District
Landisville, PA




Have you tried using the Preinstalled / Software option in Composer to build
your package?

-- Mark Sampers
Technology Support Cluster Specialist
Independent School District 196
Rosemount-Apple Valley-Eagan Public Schools
3455 153rd Street West
Rosemount, MN 55068

Valued Contributor

According to the documents from Microsoft and JAMF, you should be able to
simply drag and drop the 'Office 2011 14.1.0 Update.mpkg' into casper admin.
Both specifically talk about the 14.0.1 update, but in theory it should be
the process for all future updates from MS.

Have you tried that?

I haven't had a chance to work on it yet.



This worked for me. Worked great.

Valued Contributor

I did exactly what Jason describes and it has worked perfectly.

Tom Tubbiola
Design IT

Not applicable

The reason it does this is because the update includes files within the applications, without changing all of them. Composer uses Mac OS X built-in frameworks to produce the icon you see, and as far as Mac OS X is concerned, those applications are invalid. This is because not all the pieces were changed in the update. Make sure you use New & Modified snapshots for updates, and I strongly recommend keeping track of file deletions as well. Or, better yet, just drag the mpkg as many others have suggested.

I wrote a script that takes care of that stuff for those applications that use drag & drop installation (.app within a .dmg, usually). Basically, it deletes the entire application before the update is installed.

It would be nice if Casper provided a clean, automatic way to do this. Treating bundles as atomic would be a great start, but there would have to be a way to override it.

Valued Contributor

I was unable to get SP1 to work in my Modular imaging method or doing a
Composed image. My work around was doing an image capture of the Base
Install of 2011 and than running the installation of SP1. Works perfectly
and the standard installer works great for upgrades only.

Matt Lee
FNG Sr. IT Analyst / Desktop Architecture Team / Apple S.M.E / JAMF Casper
Fox Networks Group
matthew.lee at

Need Help? Call the Help Desk at (310) 969-HELP (ext 24357) or online at
http://itteam <http://itteam/>
Help Desk Hours: Mon-Fri, 6AM-6PM PST