"Allow Deferral" not working correctly with policy.

New Contributor

We have started pushing OS X upgrades via Casper! We have three policies. The first policy that runs is a script that triggers another policy to cache the OS X installer. Once the cache completes, it triggers the third policy that runs the installer and restarts the machine. Everything works perfectly, except for the ability for the user to defer the process in the first policy. We have allowed "User Deferral" but when they choose a deferral time, the policy marks as complete and never prompts the user again regardless of the amount of time the user selects for deferral. Anyone have an idea of what we are doing wrong? I've attached an image of the deferral page to make sure there isn't anything configured incorrectly there. The script/policies itself will run fine and cache/install with no issue if the user selects "Start Now" instead of deferring.

The reason we have multiple policies is so the user can cache the installer via out local distribution server, and then install whenever/wherever. If anyone has a better way of pushing OS X upgrades, let me know :)


Valued Contributor II

@chris.glaske the deferral issue is a know product defect. The reference is D-010208. Policy deferral worked normally through 9.81. After that it broke. I'd suggest contacting your TAM and referencing the above defect number.

New Contributor

Thanks for the quick response! I'll contact them today.

Esteemed Contributor II

Why not proactively cache the installer.

Saves the user having to sit and wait for the download...and user gets to defer the install. ;)


New Contributor III

@chris.glaske. I have it as a 'product issue' PI-002338. I'm still not sure what the difference is between a 'product issue' and a defect. The deferral never gets scheduled to run regardless of frequency.