"macOS wants to make changes" when applying a Restrictions profile.

catesr
Contributor

Obviously a no go considering these are student machines. If I click cancel the message goes away. just wondering what would cause this and will there be trouble in the future. The profiles are being installed at the User level. All of our computers are running Catalina. Thanks.

9 REPLIES 9

sdagley
Honored Contributor III

@catesr How are you installing the profile?

catesr
Contributor

I'm simply creating the profile and scoping to our students? Does that answer your question?

sdagley
Honored Contributor III

@catesr Are you creating and deploying the profile as a Configuration Profile in Jamf Pro? Or are you trying to deploy the Configuration Profile via a Policy?

catesr
Contributor

Sorry I'm a bit dense. I'm creating the profile and replying as a Configuration Profile.

sdagley
Honored Contributor III

So much for that theory then. I've not seen this behavior before with Configuration Profiles, not that's it's appropriate for EDU use, but I typically install User level profiles via Self Service so they'll install immediately as opposed to some other random time/user login one typically gets with User level profiles. Have you tried installing at Computer level? And out of curiosity, how were these Macs enrolled in your Jamf Pro instance? (Not that a Restrictions payload requires UAMDM)

catesr
Contributor

They're enrolled via DEP. I might test the Self Service thing just to take a variable out of the equation. I will also try the Computer Level as well. Appreciate the fast responses.

em_e
New Contributor II

What's the Config Profile that you are installing? We had this issue when the profile had "Require Authentication" on for the Internal Disks in a Restrictions profile.

wifichallenges
Contributor

Hey did you ever figure this out? I think this is why my mac wireless certificate profile keeps disconnecting. Basically i have wireless before login, then this prompt comes up during login, i click cancel, and i lose wireless. This is on a new signin of a limited user.
634d8280f6ea46ca97b8c3437275a5c5

I_AM_ROOT
New Contributor

Im having the same issue as well. I manually add the profile onto the end users machine, since we need to remove it, to re authenticate onto the network servers.