Recon Having issues after 9.81 upgrade

New Contributor

Hi All,

We have recently upgraded our environment from 9.73 - 9.81.
Before the upgrade I was using Recon's Network Scanner quite effectively too, every time I ran the scan I would enrol 2 - 20 computers at a time and it would finish the scan reasonably quick as well.

Now since the upgrade when I run the same scan, it starts off fine by finding a few devices but within 30 seconds or so it starts to lag or become non responsive and doesn't seem to work at all(as attached) and has to be force quit.

Any insight on this would be much appreciated.



New Contributor

I second that. Recon 9.81 never runs a full Network Scanner enrollment... have tried it on multiple LAN's and machines/OS's. It just freezes, usually within the first 5-10 seconds, then is useless until I remove the plist's and default the application. Remote Enrollment works better if you just pick off one-by-one on your LAN, but that eventually gets a hiccup as well and needs to be defaulted. We're having the problem with a bunch of clients not checking in with the JSS, and re-Reconing them fixes them... but it's tough to do when Recon doesn't work properly. :-(

New Contributor

I'm also having this issue and it's becoming a real pain and we have a number of Macs that need their JAMF binary upgrading due to a previous issue where all machines became un-enrolled. @McNeil would you be able to provide more information about your workaround? Thanks!

New Contributor

Unfortunately, I don't really have a workaround because it eventually quits regardless. When I default it, I just remove any JAMF plist in /library/preferences and ~/library/preferences... but again, it just quits shortly after I re-establish everything. I eventually started using ARD to push out policy update commands (i.e. "jamf policy") scheduled for every hour, and created a package to run a full recon through ARD as well when needed. Within a week or two, I had hit pretty much all our clients and weeded out the remaining and resolved those issues individually. ARD is far from great software, but I find it's a good alternative when parts of the Casper suite aren't working properly. Hope that helps!

New Contributor

I started seeing this behavior last week while running Recon manually on machines. It would hang at gathering hardware info or application usage. This was on fresh machines that were being enrolled for the first time. A force quit and a second run would usually work.

New Contributor III

I'm seeing this while running 9.82 recon. Anyone find a workaround for this?

New Contributor

Recon 9.9 has the same issues. It freezes after a number scans