self service 8.22


Hi All,

Recently updated to casper 8.22 from 8.21 and now self service no longer works,

As always i have login required but local authentication not required, this has always worked up until now.

Now when anyone uses self service and installs an application it prompts for admin rights before it will install,

anyone else seeing this?

i have tried jamf update , jamf manage , removed the old self service and reinstalled but still no go

tried self service version 8.21


Criss Myers BArch
Senior IT Analyst (Mac Services)
iPhone / iPad Developer
Apple Certified Technical Coordinator v10.5
LIS Development Team
Adelphi Building AB28
University of Central Lancashire
Preston PR1 2HE
Ex 5050
01772 895050


Esteemed Contributor
Esteemed Contributor

Maybe the mac has become unmanaged somehow?

Can you run a quick add on it then try?

Honored Contributor

Self Service did get updated in 8.22 (mine shows v 8.22). I haven't updated our users' Self Service just yet (they're on 8.1) and we see some odd formatting issues - like CSS incompatibility or something - but it hasn't effected functionality. I've cleaned up my policies to strip out all HTML so that later this week I can push the new Self Service to folks.

So, perhaps it's an incompatibility you're seeing? You can download the Self Service app from the JSS admin console to put on a test box instead of blasting it out to everyone.

Jared F. Nichols
Desktop Engineer, Client Services
Information Services Department
MIT Lincoln Laboratory
244 Wood Street
Lexington, Massachusetts 02420

Not applicable


I've seen this recently as well, but it happens to start after the upgrade to Lion. It seems that the hidden casper management account gets out of the admin group when Lion is installed.

I used a policy to push out the quickadd to all Lion macs, and Self Service began working as expected. Hope this helps.

Jon Taylor
Apple Specialist - IT Consultant

Kinetic Technology Group


I'm on 10.6 and we have redone the admin account on all clients and jss

Plus casper remote works which uses the same details

Criss Myers

New Contributor III

Has it been confirmed yet wether they will be addressing the issue with HTML not working any more?

Have they removed this feature?


John Szaszvari
Network Manager | Monte Sant' Angelo Mercy College