Self Service Printers that Worked on Mojave Not Working on Catalina

Valued Contributor

Hi All,

We make printers available in Self Service on an as needed basis currently (as there is no way to connect our print server and Jamf). We had much success in Mojave with the following:
-For our HP Printers and Kyocera Printers we deploy it as a generic post script printer.
-For our Xerox Printers we deploy the drivers from Xerox.

We have run into many issues with Xerox on Catalina and I can't figure out the issue. It is saying the following. We are Windows print server if that helps!

Should the PPD in Jamf be the path to the Xerox one? It is a .GZ so I am not sure how to get those to PPDs.

Any help is much appreciated! I attached the email failure and the current policy.




Valued Contributor III

First thought that comes to mind is checking whether you’ve dealt with authentication issues perhaps?

Contributor II

We have had to update Xerox drivers for Catalina. And reset the printing system before re-adding the printer in System Preferences.

New Contributor III

Have you checked to make sure the xerox drivers even support catalina... ive had bad luck with some of the xerox drivers. On a side note we now use Papercut for macos printing, it solves issues like this.

Contributor III

@WBS What Papercut solution has solved your issues, Print Deploy? If so, don't you still have to maintain printer drivers on a reference computer?

New Contributor III

@MrRoboto MobilityPrint , I just add a printer into my windows printer server just like i would for my windows clients then set who i want to allow to print to that printer in papercut. When you go to printers & scanners in system preferences, You just click the plus and select the printer you want to print to. No drivers to worry about and its easy for users to add any printer they want. It saves us so much helpdesk time that its worth every penny. Also works great for chromeos clients.