Software updates not installing

Valued Contributor II

I've been having a problem installing iTunes through the Apple Software Update cacheing server on OS X Server. it seems that when it tries to install it errors out saying the install is corrupt. what's the easiest way to clear our the update and have it re download?


Contributor II

You'll have to login to the server, or server app and delete the problematic update(s).

Remove software updates You can remove software updates from your Software Update server using the Server app. Select Updates In the Software Update pane. From the list of updates, select the update you want to remove. Click gear and choose Remove.


/Library/Server/Software Update/Data/html/content/downloads/

This should trigger the service to re-download the update again.

Esteemed Contributor
Esteemed Contributor

@jwojda Is this caching or Apple Software Update Server?

Valued Contributor II

it's's SU cache. I found some old instructions from AppleCare support, but they screwed up the config file. I tried following a workaround on your site, but it didn't work. I just found out how to uninstall and reinstall, so I'm trying that now.

Reinstall thank you for that! I tried it, and the newer versions of are a little different, but it didn't work.