Something change with 'Waiting Room' ?

New Contributor II

Did something change with either an update in Jamf Pro Cloud or with macOS 12.x regarding the 'Waiting Room' folder?

Have a script that worked great until recently.

sudo echo "---OUR SITE CODE---" > /Library/Application\ Support/JAMF/Waiting\ Room/com.sentinelone.registration-token
sudo /usr/sbin/installer -pkg /Library/Application\ Support/JAMF/Waiting\ Room/SentinelAgent_macos_v21_7_4_5853.pkg -target /

I am getting this when that script runs from a policy

Script result: /Library/Application Support/JAMF/tmp/Install SentinelOne: line 1: /Library/Application Support/JAMF/Waiting Room/com.sentinelone.registration-token: No such file or directory
	installer: Error - the package path specified was invalid: '/Library/Application Support/JAMF/Waiting Room/SentinelAgent_macos_v21_7_4_5853.pkg'.
	Error running script: return code was 1.

In looking on the machine, there is no /Library/Application Support/JAMF/Waiting Room/ folder. Did that functionality move somewhere else? Or is there a better way to push that down? Not seeing any new documentation on the SentinelOne knowledge bases.



Legendary Contributor III

If you have not previously cached a package to that Mac in a policy, the Waiting Room folder may not exist. Certain folders get created when they are needed for the first time, and I believe the Waiting Room is one of them.

You have 2 options. Either run a caching policy first to cache something, which creates that folder. Or, create the folder yourself if it doesn't exist.

Only thing with the second option is, I would check out what POSIX permissions are set on an existing Waiting Room folder and match them if you create it. I believe it has 700 POSIX applied, so that only root can see the contents of the folder or something like that.

Contributor III

I didn't have a Waiting Room either. Not sure if it's because I hadn't previously cached anything on my test Mac or it Waiting Room was removed during the 10.38.1 jamf agent update... I suspect it's entirely the former!

New Contributor II

Uggg.....the policy that was set to 'Install Cached' got changed to 'Install'. I think that is probably the issue.

Legendary Contributor III

If an updated pkg was added to the policy at some point, that could explain it. Packages get added as “Install” by default unless you change it to “Cache” or something else.