SPSS 28 Concurrent Licensing Issues

New Contributor III

IBM normalized their installation namespaces on Mac/Windows, and changed where they store the license server settings inside a file called "/Applications/IBM SPSS Statistics/Resources/Activation/commutelicense.ini".

I wrote a script to update this - its similar to the spssprod.inf file. On launch however I get this popup:


Clicking "apply existing license" goes right into the app and checks out a license. The warning doesn't come back.

I found that some setting (where I'm not sure) is stored in a file called "com.ibm.spss.plist" in the user profile preferences folder. I can't of course just copy this over to an existing profile because it has many hard coded paths to my user profile inside it.

Anyone else run into this issue? I'll likely bounce the issue off IBM support, but I thought I'd ask here as well.



I've been doing the same process you've been doing for years and I'm getting the same result. I went to running this script post install and seems to make everything work as it should.


SERVERPATH="FQDN Server Goes Here"
ACTIVATIONPATH="/Applications/IBM SPSS Statistics/Resources/Activation"


Hi There,

I have tried the script and it is working well. However I am still getting the pop up window?

Would you have a fix for it?

Thank you very much for this, worked first time!

The policy is the SPSS package and this script with the license server set to After

Valued Contributor II

@Angelworks @mgshepherd 

do you know if IBM SPSS 28 also has the silent_install.dmg?

I've been waiting for an answer from IBM and from people that have access to check but it's taking forever

SPSS 27 and earlier had the silent_install.dmg so hopefully 28 does too.  thanks

New Contributor II

I am having the same issue with this popup, except we are using local licenses instead of a license server. Any idea how to circumvent this pop up?

New Contributor III

@JHerrin, we're in the same situation. Did you ever manage to get this figured out?


Thank you!

New Contributor II

Yeah… but it was pretty hacky. I spoke with their support and they said
that for proper licensing and install the install package had to be called
from an install script. So I created a new package that placed their
package into a temp location. Then used post install script on the new
package to call their package and license. --
James Herrin Jr
*Desktop Support Group*

New Contributor III

Thank you for the quick reply! Is that script (without any information about your license or institution, of course) available somewhere?

New Contributor II

Here is what I used.


## postinstall

sudo installer -pkg /private/tmp/SSC_28.00.00_MacOS.pkg -target /
cd "/Applications/IBM SPSS Statistics/Resources/Activation"
./licenseactivator f5555d4e3d5555c82544

exit 0		## Success


New Contributor III

Thank you! I'm embarrassed to say that I misunderstood my own environment, and actually was able to use the script posted earlier in order to use our license server (we have both a server license and local licenses).


Just a heads up, you may want to make sure that the last part of your script isn't a license code. I haven't tested your script but you probably want to make sure that's unpublished if it is 🙂


I'm having difficulty with licensing (new licenses on the server), it was fine rolling out earlier versions of 29 for the Sonoma fix but now I can see the licenses in License Wizard in, commutelicense.ini has the correct data but the App does not launch.

I don't see the difference between your script and deploying by Policy then running licenseactivator and a command or within the earlier script. Did you make the change to putting the .pkg in /tmp after the previous solution failed and did that fix it?

New Contributor

Same issue with v29 of SPSS