sudo jams policy not finding policy triggers that exist

Contributor II

Perhaps this has been discussed elsewhere but I am unable to find a specific post regarding my issue.
We are using JSS 9.82 and for some reason I am unable to get a policy to run that has run before on the same Mac.
When I run a sudo jam policy the resulting text states "no policies were found for the "recurring check-in" trigger.
manually initiating other triggers for the policy also state no polices found.
In the JSS I can go to the computer management Inventory and see the policy under the Management section but the policy refuses to run for some reason, stuck at "pending"
Any ideas as to why this does it.
We will be upgrading to JSS 10.2 in a few days so will also see if that fixes it.


Valued Contributor III

Client side restrictions set on the policy and it's outside the allowed hours possibly?


Execution Frequency set to ongoing? the computer is in scope of the policy?

Valued Contributor II
get a policy to run that has run before on the same Mac

the first thing I check is whether I have the policy set to run ongoing, or do you need to flush the policy history to have it run again. The other thing I run into is some sort of exclusion that I'm not foreseeing - is it a member of a smart/static group that has it excluded and I didn't expect that. For me, our encryption policy was set to run against 100% of our fleet, but we had built a delay in by excluding certain IP ranges used for building out workstations. So the policy wasn't running during its build while on build segments. check it's Management/Computer groups to see if there's something there that would be excluding it.

Valued Contributor II

...Also - what is this policy doing? Software install? system cleanup? running a script?