Suppressing AppleID prompt for Adobe Install User in El Cap?

New Contributor

Greetings all,

I work at a K-12 with a Mac 1:1 program for several grades. We're doing our big summer overhaul and re-image, and I'm hitting a wall trying to stop the Apple ID signin prompt from appearing, and effectively pausing imaging halfway through, for the Adobe Install User before the black "Finishing Installing Software" screen.

I've seen several threads on suppressing this prompt in the past, including , , , , and Rich Trouton's scripts that they link out to. We've tried lifting the various scripts described and implementing in our imaging configs, with no luck.

I eventually ended up writing preference keys:

DidSeeCloudSetup = 1;
DidSeeSyncSetup = 1;
DidSeeSyncSetup2 = 1;
LastSeenCloudProductVersion = "10.11.3"

...into /System/Library/User Templates/Non_localized/Library/Preferences/, and to the English.lproj equivalent thereof, on our base image, which seemed to work briefly, for both the Adobe Install User and manually created test accounts we made on machines after they were imaged.

However, now we're back to the same symptoms.

You probably noticed above that I used "10.11.3" above, that's because we're imaging to that version because of the 10.11.4-and-later issues with 13" MBP Retinas, which make up most of our 1:1 fleet. (While we've seen articles advising updating to 10.11.5 and having the latest version of Flash, we've also seen chatter indicating the problems may persist for some, so we're just hedging our bets for now.)

I suspected that perhaps Apple had upped the live version that preference key is checked against, and tried upping it to 10.12 just now in a fit of nerd rage, but the AppleID signin still keeps popping up for Adobe Install User. I did check the User Templates content on imaged machines, and the preference keys are showing up there as expected.

One of Rich's posts at has comments indicating this has broken for others under El Capitan too.

Anyone else running into this / managed to squish it? Thanks for any help...


Honored Contributor II
Honored Contributor II


Using scripted methods or config profiles work ok for us. The last seen versions must be equal to or higher than the one on the target Mac though.

If it's stopping the imaging process, you'll need to make sure a script runs to apply the setting before the Mac logs in to the account for the first time.

We've always set it as a script to run at reboot before anything else and it works ok.

Contributor III

I use as script by Rich Trouton @rtrouton to disable the iCloud pop-up

Works for me. Might be worth looking into!

New Contributor

I've tested both with our spinoff of Rich's script, and his script verbatim, set to both "After" (after the first wave of packages but before reboot) and "At Reboot", but it still doesn't suppress.

May I ask what priority options you're using for your copies of the scripts, and, what versions of Casper and imaging type (target, pre-stage, standard...) you're using?

New Contributor

(David, any scripts that we have set to "At Reboot" always show up at the end of the list in Casper Imaging -- and I think they all seem to execute late in in the process in /var/log/jamf.log -- though we unfortunately just enabled the policy that nukes the log file to hide traces of our hidden admin accounts, so that's going on memory, not citeable... is there some trick we need to add?)

Contributor III

Priority is set to At Reboot for this script. I have been using this script with Casper Suite v9.61, v9.81 and now v9.92. Mac OS versions 10.10.x and 10.11.x.

I have found that iCloud still pops up with the hidden management account. Not sure why!

Valued Contributor

hey @stevevalle

it may be possible that the management account is created before the script runs. I use createuserpkg in my autoDMG image and used to see this. but as per @stevewood in this post, I was able to resolve it