Unable to change password via JAMF Connect - Unable to reach any KDC in realm

New Contributor

Hello all,

Let me start by saying that I'd consider myself a junior JAMF admin. I've got a user that reached out to me because they were trying to change their password via JAMF Connect > Change Password, which works fine for all other users.

When she tries to do it, she gets an error "unable to reach any KDC in realm xxxxxxxxx.com, tried 0 KDCs" (realm redacted).

I've found some information saying that a krb5.conf file needs to be placed in /etc, and tried that to no avail. 

The realm in the message is not our actual domain, which is odd. The realm it is showing is actually the end of her email address, which is part of our domain. So say her email is lsmith@presidentialdrinks.com, but our domain is productjb.com, it is showing the realm as presidentialdrinks.com.

The machine was not bound to AD, so I binded it through Users & Groups, and still getting the same message. 

I was able to manually reset the PW through our AD system, and JAMF picked up on it and made her update her local password, so it's talking to our systems. 

Any help would be greatly appreciated.