User and Location information multiple devices JSS 9.3

dvasquez
Contributor III

Hello
Anyone unable to add location information such as department and building for users that own multiple devices in JSS 9.3? To clarify I have some users that own or use more than one system me included. I am unable to add department and building for more than one system owned by that user. This was fine in 9.25 and before. After upgrading to 9.3 I am unable to do this. If I do edit one devices location information it removes it from the other owned by that user. I tried the database repair and checked tables, etc.. I stopped Tomcat before running the repair. Maybe it is nothing, maybe it supposed to work this way, maybe it is a bug in 9.3 or maybe it is my DB acting up.

to clarify: A user with multiple devices I am unable to add Department or Building to their other devices successfully. The information will not save it will only save on one device. All other information is present when adding the same user to another device. I am using LDAP to get users information. The departments and buildings are done manually. I do get room info after adding the users from an LDAP query.

I am not over riding the building and department per subnet because I have too many different departments in one subset in some of my locations.

Hope this makes sense.

Anyway I am just reaching out.

Thank you.

9 REPLIES 9

jhbush
Valued Contributor II

@dvasquez I can confirm I'm seeing the same thing here as well after the 9.3 upgrade. I tested your theory by assigning a problem machine to a service account and the building info stayed.

pblake
Contributor II

I brought this to JAMF last week. They confirmed it as a bug and it will be fixed in 9.3.1.

yan1212
Contributor

Yes, exactly the same problem here with 9.3. Logged a call with JAMF earlier today...

dvasquez
Contributor III

Thanks guys. I figured something like that was up. Hope 9.3.1 is available soon.

Thanks again!

dvasquez
Contributor III

Sorry adding this to this discussion:

Anyone seeing clients removing them selves form smart groups automatically? Clients or objects that have the correct criteria.. this is very troubling.

Today I am seeing objects removing them selves from my smart groups for like "Mac Pros" all by themselves.. I am not sure why this is happening.. If it continues I might just restore my 9.25 database.

And to make it worse if you try and edit the smart group items are removed after save. Maybe, I hope, I am just seeing this problem.

dvasquez
Contributor III

Ok well I deleted the smart group and then re-created and added criteria and things are better. I am checking with others now.

Sorry.

jhbush
Valued Contributor II

I'm also seeing double entries for location history. One with room and building info and one without both with same timestamp.

external image link

pag
New Contributor

@dvasquez I was facing a similar issue with JSS 9.3 and LDAP. This was fixed for me by upgrading to JSS 9.3.1.

dvasquez
Contributor III

I see this issue is gradually going away for me. Although I have seen it once or twice sense the upgrade to 9.3.1. Thank you for your contributions.