User-initiated computer enrollment now using Quick Add

New Contributor


We've recently noticed that user-initiated computer enrollment is now using a Quick Add package when previously users who initiated enrollment would have to download a CA certificate and MDM profile. This has been causing issues as the Quick Add package has not installed any of our Profiles and while those computers appear in Jamf, we are not able to push any management commands. This has happened with DEP enrolled machines too.

Our team hasn't made any changes to the enrollment as far as I know.

Any assistance would be greatly appreciated. Thank you.


New Contributor II

I am seeing this in my environment as well. 

New Contributor

It's very strange. For DEP enrolled machines, you'd get at least the MDM profile installed and then I have to run 

sudo profiles renew -type enrollment

Sometimes that alone fixes the issues but most of the time I'm restarting the machine and running the policy and recon jamf commands to get it all working like before. 
This biggest issue is the user initiated enrollments. We have a couple of problem there:
1. the invite enrollment link returns a forbidden error

2. logging into /enroll and downloading/installed the QuickAdd package does not install any profiles. Even when prompted by Self Service to accept the MDM management, no MDM profile gets install nor can I run the command above to fix the issue. (I can run the command but no profiles get installed)

New Contributor II

I have noticed this in my environment TODAY

I recently just "renewed" our CA cert a few days ago

Have any of you done the same?

It is up and running again

Not sure what version of Jamf Pro you are using 

But under 

Computer Management - Security

Make sure that Push Notifications are enabled (apparently one of my team members disabled it)

Hope this helps



New Contributor II

I'm now experiencing what you are when attempting to use the user initiated computer enrollment. No settings were changed and I keep seeing this Quickadd package. macOS's are version 13.4...Was there a fix to this?

New Contributor II

OK, I just figured out why in case this helps someone in the future. My Push Certificate expired a few days ago. Once I updated it, I was able to re-enroll the Mac's. 

New Contributor III

Nice one Punchy, we were having this issue and this was the problem for us too. We renewed the MDM Push Cert and enrolment is working as expected correctly. Thanks

New Contributor II

Glad it worked!