VirtualBox on Mojave

New Contributor III

Hello Jamf Nation,

I have a request to upgrade VirtualBox to the latest. It was working fine in High Sierra but once our cloud engineers upgraded to Mojave the application no longer works.

Me and 2 other Mac technicians have tried to install and run VirtualBox latest 6.0.8 but have received numerous install errors. We were able to get 6.0.4 and 5.2.32 to install but cannot get them to work. I can point it to an ubuntu iso and it begins the install process but eventually either freezes or another error is received (multiple errors have been encountered).

*Note: We have the Oracle America kernel extension whitelisted in our Config Profiles. We didn't change it at all from when it was working in High Sierra.

My question is:
1. Does anyone else use this on Mac in the enterprise?
2. If so, have you been able to get it to work on Mojave?
3. If so, did you have to do anything special to get it to work? Any tips on getting it to work.

Any help is greatly appreciated!!!



I did this on my personal Macbook running Mojave and didn't have any problems installing VB. I have yet to set up a VM in it but the install went fine.

New Contributor III

Hi edickson,

Thank you for your response!

We have had success installing manually. But our engineers (who do not have admin rights) are requesting to have it packaged and mass deployed.

Have you been able to package the latest version successfully on Mojave?

*Note: I have found that the Extension pack is absolutely needed to do anything with VirtualBox. Specifically, add a network connection.


Have not deployed it in a mass environment yet but I'll update this post if/when I do.

New Contributor II

Just tried to install VirtualBox 6.0.12 and ran into the same issue. Turns out they added a new KEXT (org.virtualbox.kext.VBoxNetAdp) that just needed to get loaded into the Configuration Profile and deployed prior to running the install.

New Contributor III

I was able to get this to work on Mojave. Here are my packaging tips for anyone else reading this:

  • This application has a kext for Oracle America added to the Approved Kernel Extensions policy.
  • This application does not seem to work at all unless the Extension pack is also installed.
  • When making the package, just open the DMG and copy the pkg to Jamf Admin. The pkg seems to have scripts that are needed for the application to run right. I was seeing some versions (6.0.6 and 6.0.8) failing at the end of running the pkg manually.
  • The uninstall VirtualBox script unloads and removes the kext so I took that out of our policy as I think it was removing the kext.