VPP Installation issue with Monterey

Valued Contributor

Have a set of machines that we're adopting and for whatever reason, pushing VPP apps to them, I get "Invalid Status Code" in Jamf Pro, and the apps don't install. 

These are running Monterey. I haven't seen this issue with other machines, but I'm not 100% sure if it's these specific machines or something else. 

Curious if anyone has seen this. I did see this community thread, and did disable this option. No change, sadly. https://community.jamf.com/t5/jamf-pro/fix-for-vpp-apps-not-deploying-in-big-sur/td-p/225620


Contributor III

I am seeing this behavior on macOS Monterey v12.1 with the learning Ally App. Invalid Status Code  is the error message the pops up when trying to install the app. 

Valued Contributor

So, turns out, it's related to language. Opened a ticket with Jamf, and they said the language needs to be English, and the primary input needs to be English. And not just English, but US English. 

What I got from Jamf

1. In Terminal, run the following. defaults read /Library/Preferences/.GlobalPreferences.plist AppleLanguages

2. If "English" perform the following sudo /usr/bin/defaults write /Library/Preferences/.GlobalPreferences AppleLanguages -array "en-US"

3. Restart the computer, then run the following commands in Terminal defaults read /Library/Preferences/.GlobalPreferences.plist AppleLanguages



Ok, I wonder what the fastest way to automate setting English as the main language is with JAMF on macOS 12? 

Valued Contributor

I just used a script fired by policy to run those. Config profile would work, but it would lock the language to en-US. 

I am going to try: 



sudo /usr/sbin/languagesetup -langspec en-US



Valued Contributor

let me know. I was working with Monterey myself and those are what Jamf supported provided. 

New Contributor III

Just wanted to add to this thread - saw the same "invalid status code" during VPP installation of an app on macOS 12.1. Used Jamf Remote to quickly issue above command  (/usr/bin/defaults write /Library/Preferences/.GlobalPreferences AppleLanguages -array "en-US") followed by a remote reboot, then app installed correctly on next push.


Out of nowhere, this Invalid Status Code shows up, there are no changes to my end for the past few days and I am just scratching my head how and why this will happen. Even I run the command, half of the apps are still failing until I cancel the failed commands. 

I just put in an urgent ticket with JAMF and see what they have to say.

Valued Contributor

it's client side. make sure you're getting back en-US when running the above. You may need to reboot, you'll also likely need to clear the failed commands, then do a recon so Jamf re-pushes them. 

tbh, I have no idea what happened. I just erased the same Mac, let it goes through Automated Device Enrollment, and the apps are coming back.  I do have issues with profiles getting pushed over and over, just one hour the device received over 1000 commands for the same profiles.

Valued Contributor

I've seen that with machines that don't have approved MDM on older jamf versions where it keeps trying to push some profile that requires MDM approval, but doesn't stop trying. 

Anywho, glad it worked. =)