Wake on LAN

fspa9686
New Contributor II

Hello Nation!

Noticed an older Wake on LAN policy that we have here in our Jamf Pro is returning errors. The command that the policy pushes is systemsetup -setwakeonnetworkaccess on and this is the Result of the command:
2022-03-25 10:57:04.301 systemsetup[90262:4178974] ### Error:-99 File:/System/Volumes/Data/SWE/macOS/BuildRoots/533514bb11/Library/Caches/com.apple.xbs/Sources/Admin/Admin-911/InternetServices.m Line:379
setwakeonnetworkaccess: On

 

My first guess was that the computers that were getting the error may have the setting already enabled, but after unchecking the Wake for Network box in the power settings and redeploying the policy to a device to test, it still returned the same result. When resorting to Google-Fu, outside of using a homebrew pkg or pearl, I mostly saw others use the same command as myself to enable wake on network. Did the newer macOS updates change anything that I am missing that would affect this, or is there any other method that doesn't involve homebrew packages/commands that I can use to see a better result.

 

Thanks in advance!

-Frank S.

1 REPLY 1

Hugonaut
Valued Contributor II

@fspa9686 

I recommend using a configuration profiles. Under the Energy Saver payload you can select "Wake for Ethernet network administrator access" - You will want to modify all of the other settings in this payload as well to match what the end users expect or what your preferred managed settings are.

 

Screen Shot 2022-03-25 at 3.46.49 PM.png

This checks the box inside System Preferences -> Battery -> Power Adapter (Depicted below) if on MacBook.

 

Screen Shot 2022-03-25 at 3.48.25 PM.png

________________
Looking for a Jamf Managed Service Provider? Look no further than Rocketman
________________


Virtual MacAdmins Monthly Meetup - First Friday, Every Month