Xcode 12.5.1 VPP not installing


Has anyone had issues updating Xcode to version 12.5.1 on Big Sur computers or even just installing either automatically or via Self service? Automatically does not run at all and Self Service simply states -Error


New Contributor III

I notice this with larger applications like Xcode, Final Cut, etc. Typical behavior we see is the app will error in Self Service multiple times. You may notice an app stub (30MB or so) for Xcode appear in /Applications. Eventually, the application will install and appear as the full size. 


With that said, if anyone has any other tips besides trying multiple times and waiting I am all ears. 

It is not working for me at all... no stub at all! Really troublesome... Final Cut works fine

Contributor II

If you look at the device inventory in Jamf Pro and look at the Management Commands for the device, do you see any failed events? I currently have this issue with MS Excel, License not found. Plenty of licenses available looks to be some sort of communication issue.

New Contributor II

Same issue. 12.5.1 via self-service appears to time out without any fanfare, but the end result is that Xcode is not installed and no error is given. Subsequent attempts result in a "failed" error.

Contributor II

I get for Xcode Duplicate request as failure but I didn't requested more than once.


New Contributor II

What is seen here, is that on XCode install from "Self Service" it shows an error ("Failed"). 
This operative leaves that, and then as root in the terminal:

find /private -name '*.pkg' 2>/dev/null

You'll see it there (if the VPP god is smiling on you) with a randomized filename and when run again you'll see it's still alive, downloading... file size growing. When a bit more than 11 Gigs,  and stops increasing in size, run:

installer -pkg /private/var/...{whatever} -target /

Even that may take 20-30 minutes to complete, but usually does.

The mistake is in taking the Error at face value and clicking "Install" again, or "Open" (which sometimes appears), all is muddied in that case...

I believe I am seeing the same issue, although waiting the 20-30 minutes I am not seeing the install.  I even let the Macbook sit overnight and no XCode has loaded.  


Based on your post, some clarifications:

1. When you are mentioning the "find /private -name '*.pkg' 2>/dev/null" typed into terminal, is there anything typed before this line?  I tried exactly as typed and I don't get any response in Terminal just a new line.

2. If I did take the Error at face-value and clicked Open and then Install after the failed notification, is there a way for the Mac to forget my previous mistake?  


Thanks for any support.  This is the first one I am seeing, but also the first one that I have tried installing on Big Sur.


I take all that back.  I go to cancel the "Duplicate Request" command in my JSS and Self Service switched the XCode app to Open and it is not in my Launchpad.  I also ran a sudo jamf recon, but I believe I started running that after the XCode appeared. 

As mentioned in the post, the find command must run as 'root' so you likely want to prepend the command with sudo e.g.:
"sudo find /private..."
The "2>/dev/null" part sends errors to oblivion so what is likely seen as "new line"  output  is likely "permission denied."

Sounds like you got it going... this XCode install is most unintuitive behaviour.

Contributor II

@craig_sadler it resolve, It was just matter of time. After certain time it finish the install from VPP account. thanks for your reply.


I'm doing the whole Xcode dance right now. Anyone have any updates on this issue for their systems? I have a few that I can't tell if I might as well just wipe at this point because I tried to install it after the initial failed message.