iMovie for iPad says installed on JamfSchool but its not showing on device

New Contributor

Hi Everyone!
does anyone have any idea why the managed iMovie app will say its installed on the device but not at all appearing on the home screen nor listed under apps in the settings page?

The user had originally decided that they would install the app themselves but it kept asking for an apple ID.
I uninstalled the app and sent it to the ipad using jamf.
Jamf reports that the app is installed but it really seems that it hasn't done so.

Has anyone come across this? How did you solve it?
The iPads were bought this year (2021) and are iOS 14.4 and 4thGen iPad.

I have tried removing the app, resending the app.
i did a "check media status" where it supposedly checks the status of the app on the device, on the app and that too came back with all green ticks.

Is anyone able to offer any pointers? i have added a few screenshots in one image file below.

Many thanks for any help to solve this.


New Contributor II

hi, is there a home screen layout configured that does not include iMovie? Happened to me with an app and almost drove me crazy.


I ran into a similar issue with the native Apple apps typically included on the shipped devices. If the device was ever erased or restored to factory, the apps would not be reinstalled. I didn't do much research on it, but I did figure out a way to overcome the issue. I would go to my Apple School Manager account and purchase all of the native apps for that school's devices and set them to install with a base app profile.

I do realize this isn't the same issue you're having, but maybe creating a separate app profile to install the app as a test. Also maybe look at the 'Advanced' app settings to see if there's something checked/unchecked.

Greg Bobbett