"Added on save" bug prevalent

Contributor III

Hello all,

I was reading through Jamf School patch notes for today and two things caught my eye. All of the fixes related to OS updates and this:

  • Apps and profiles scoped to devices in device groups no longer incorrectly display as "Added on save" and "Pending" when the device is assigned to the device group after enrollment.

I had been getting around this just by removing and re-adding devices to the group. I haven't been able to test it specifically after enrollment, but I'm noticing that it is definitely still a bug outside of enrollment. Or at least for the first device I chose to test updates on.

It was in our staff device group, and I changed it to our student test device group. No change. So then I remove the group so it's in none. Everything gets removed as it should, good. Then I try to added it to the student test group again. Nothing. Going to one of the profiles scoped to that group to check the scope and there it is "Added on save", "Pending".

Restarting, removing and re-adding has done nothing to help. Annoyingly, removing the group makes the device refuse to check in until it is restarted.

Has anyone else been struggling with the same issue? Or are there any band-aid fixes?


Contributor III

Of course, as I typed the post the device was finally added to the group correctly. I still had to restart it for it to talk to Jamf School and refresh the details again.

Questions still stand.

Valued Contributor II

Reviving this for a similar issue. I have a ticket in for it, but no movement on that since I submitted it over 3hrs ago :( . 

New iPads for primary school aged kids and I don't want my field tech smudging up the screens or wasting time typing in credentials so I wanted to use Configurator to do a mass enrollment. To do that I'm turning auth off on the prestage(ADE profile in School speak) and import placeholders that have the usernames included. The users are in an ldap group that's assigned to two device groups and in testing those smart groups are applied to the device record like they should. What's not applied is configuration profiles about 99% of the time and apps about 10% of the time. In the case of apps I un-assign then immediately re-assign the user to the device. In the case of config profiles I have to edit each one, navigate to the scope and note that those devices without profiles are shown as "added on save" in the action column. Once each one is saved all is good.

What's even more odd is that if I un-assign the user thus removing the iPad from the scope the profiles install. Huh?!? 

The issue was referenced in patch notes back on 4/25/22:

  • Devices that are added to static device groups now correctly install all apps that are scoped to the device group.

But, as you have found out, the issue prevails. Support may send you a PDF for a workaround to save you from saving every profile. The workaround is to create a dummy group with no devices in it and scope all apps and profiles to it, thus forcing all apps and profiles in your Jamf School instance to save. Removing everything from the dummy group's scope also forces a save, should you have to continue to do so.

We have devices assigned to general Static Device Groups at enrollment, which seems to avoid the issue. Changing the group after that has the issue.

Valued Contributor II

Thanks for the tip. Tried it on several that I just setup and it seems to be working. My wrists and finger joints are going to be screaming at me as we have quite a few profiles and just north of 300 apps. Hopefully this will work with multiple dummy groups as this will get old pretty quick. 

Had a butt clenching moment when I accidentally assigned the dummy group to a bunch of devices. Oh well, a large portion are in storage so they won't be affected by my boneheadedness. Made a note to ensure I clicked on-demand when I create these just in case I slip up and create a smart group.

Still no response from support. Sent a "Bueller?" response to the thread.