14.8 Update issues with Apple Classroom App & Jamf

New Contributor

Hello Everyone!


I  am having issues with Apple Classroom in Jamf after the iPadOS 14.8 update deployed. We are running the Classroom app by IT manually entering the users in "user static groups" and adding in the classroom App. This is all working for one building who had all of the groups created before the update and still works with 14.8, but anything added after the update on 14.8 does not work at all. The EDU.config profile fails in jamf on that specific device. Other buildings are not working if a classroom is added after the update. All worked with the update iPadOS 14.7.1 initially setup. We are not using Apple School Manager at all.


Any advice greatly appreciated. I  am not a fan of apple deploying updates out when no beta has been released and for some reason this was a state of emergency to get deployed. Years ago back in 2013 Apple killed all connections to MDM devices doing something similar.


Thank You!



Valued Contributor II

Is this Pro or School? Have you tried an ad-hoc class just to be sure that's not broken as well?

"We are not using Apple School Manager at all."

I assume just for this purpose? How would you deploy your devices if you didn't use ASM?

This is PRO. Version 10.26.1-t1606923553. We are not using Apple School Manager which dictates classes from a .CSV file or SIS. We use other portions such as DEP & VPP. No, we do not use ad-hoc in our classes.


I  also have this working in another building fine due to being rostered before the update and after the update, and anything in this building added currently does not work with a failed EDU.config file.  The rosters were not made for other buildings until after the update and do not work.



Thanks Jamf for Fixing this...today was the day I  had time to inquire about this issue! Here is the article 



Valued Contributor II

I assume that since you're running 10.26 that your installation is on-prem and not cloud hosted by Jamf? Have you considered upgrading as the version of the edu profile being deployed by 10.26 may not be meshing well with iPadOS 14.8?