iOS devices not joining Wi-Fi when roaming between APs

burnhamt
New Contributor III

Hello #Healthcare, 

 

 I got a strange request. Not sure if this is the right thread to ask in but I will ask anyways. I have multiple iOS devices running various iOS version connected to an enterprise healthcare wireless network with the Wi-Fi Networking roaming settings by Apple. Recently we noticed when walking around that when the devices roamed from one AP to another the Wi-Fi just stop, it would take anywhere from 1-24 seconds to rejoin the network. But when you looked at the Wireless controller the devices showed they were connected. This is happening in multiple areas of our campus and in our shop with only 3 APs. Any help would be helpful.

14 REPLIES 14

ericjboyd
Contributor

Is this a Cisco network where ISE is enabled?

burnhamt
New Contributor III

@ericjboyd We use Cisco switches and use Aruba for the wireless, with clearpass for our NAC. The issue just started recently. No changes have been made recently. 

nsbickhart
Contributor

we have been dealing with this issue for some time as well.  If a device hits a dead spot, it will not auto join until the screen is raised.  Having a cellular data plan on the device has helped tremendously, as users will still receive notifications over cellular if WiFi has dropped.  Not really a great solution, but it does help.  We still use manual WiFi auth, but are trying to get mab setup and we will use a WiFi profile.  I don’t think this will help, I have to test again, but I believe I ran into the same issue even with a WiFi profile deployed.

Is it a hidden SSID?

Thank you,

Eric Boyd
UC San Diego Health

burnhamt
New Contributor III

The 2 networks with 802.1x are not hidden networks. 

burnhamt
New Contributor III

@nsbickhart@ericjboyd 

I forgot to mention that this is happening on JAMF and Intune managed devices as well as unmanaged devices. We are using 802.1x for our auth to the wireless network. We did find out that our our guest network which does have any auth is working without an issue. The seem to only be related to the 802.1x secure network. We did not have a problem with our Android or Windows devices. 

We are seeing the same thing.  We also have 802.1x enabled and our network is not hidden.  Guest doesn't seem to be an issue and we don't have enough corporate androids to dig in, but I have heard from some of the boots on the ground that they DO see issues with iOS on the guest network, but androids have zero issues.  Haven't been able to vet that, but sounds like we are basically in the same boat.  Honestly, I think our infrastructure is oversaturated with AP's, yours probably is too.  Not really sure what the solution is, but like I said, the cellular data plans have helped tremendously.  Not really a good option, but if you're in a pickle for some of your devices, you could try that.

burnhamt
New Contributor III

Not all of our devices have a cellular connection on them and the issue just started within the last week and a half. We have the same issue in an area that only has 3 APs the issue is still present. So I don't think is because we are oversaturated with APs. I have our network engineers looking into the issue and I think they are going to open a TAC access with Aruba for more support.

ericjboyd
Contributor

Are these APs on a different controller?
We found a Cisco issue:
There is an ‘advance setting’ called "DHCP Addr. Assignment" that has to match between the two controllers that are connecting to be mobility pairs. Once these two settings are aligned and match, the movement of the devices should be seamless.

nsbickhart
Contributor

@ericjboyd I'll bring that up in our next meeting.  Thanks for the tip!

nsbickhart
Contributor

@ericjboyd 

Our environment is designed with no inter controller roaming. We also do have all dhcp scopes matched across controllers in mobility groups.  We are a cisco shop as well, running 802.1x and ISE.

khurram
Contributor III

We were facing similar issues. The following were the troubleshooting steps which helped us improving the problem.

Workarounds

- restart the AP and it would help for couple of weeks

 

Solution

- make sure the APs are not overlapping the same radio settings for instance if one AP is using (1,36) = (2.4Ghz,5Ghz) channel then the neighbouring AP should use different channel for instance (11,44)

- use AirPoit Utility app and find out the signal strenght in the particular area (Note: the MAC address in this app corresponds to BSSIDs of the AP).

- using the AirPort utilitu app, do a walkthrough of the area (building/floor) to monitor the WiFi coverage. Take snapshots by standing in one area and then take another snapshot in another area and keep going through out the building then go back to desk and make a WiFi coverage picture out of it

- if you use Meraki then connect to the WiFi network and go to page ap.meraki.com this will make job easier and you dont need to use AirPort utility.

 

This was just a summary, if you need more details please feel free to contact.

JarrodRanneyPub
New Contributor

So I don't know if this is the same thing, but we chased a very similar issue in our stores for months. It turned out to be caused by having a mix of two different AP Cisco models. When a device would roam from one model to another, the auth would fail and it would have to reauthenticate, causing a connectivity drop since that device was no longer trusted. Cisco provided a patch, but we're going through and replacing APs so that each store has the same model vs mixed models.

@JarrodRanneyPub - We are a mixed shop. We use Cisco Switches and Aruba APs. We noticed the issue in areas that had brand new APs all the same model and areas that had mixed models. My network engineers made a change to the controller which seem to fix the issue. I will have to follow up with this one on what change they made.