Jamf Connect 2.3.3 Release


Hi Jamf Nation,

Today we released Jamf Connect 2.3.3 for general availability; this release includes the below details.

Bug Fixes

• [PI-008947] Fixed an issue that sometimes caused the Close button for the login window Help window to be covered by text configured with the Login Window Message (LoginWindowMessage) setting.
• [PI-008954] Network checks by the menu bar app now update the LastSignIn key written to the com.jamf.connect.state PLIST file.
• [PI-009179] Fixed an issue that unexpectedly allowed Jamf Connect Configuration to accept multiple lines of text in single line text fields.
• [PI-009673] Fixed an issue that prevented authchanger arguments passed via a configuration profile written to com.jamf.connect.authchanger from being respected.
• [PI-009700] [PI-009695] Fixed an issue that prevented the Jamf Connect login window from completing password validation (ROPG) for PingFederate users, which also caused account creation to fail.
• [JC-1938] Fixed an issue that prevented Jamf Connect from retrieving Kerberos tickets for a user when a different user that previously signed in already retrieved Kerberos tickets.
• [JC-2385] Fixed and improved some translation issues for languages other than English in the Jamf Connect menu bar app.

Product Documentation

For more information, including Release Notes, please see the Jamf Connect Administrator Guide.

Thank you!
The Jamf Connect team


Valued Contributor II

for PI-008954 this seems to only work on the background network check-in. I tried running open jamfconnect://networkcheck and the LastSignIn time didn't updated.


[PI-008954] Will this also fix the issue of kerberos not updating on network changes?

Contributor III

just tried this with a prestage enrolement (azure) and iam not getting the connect login screen, just the inbuilt macos login. Iam going to try and recreate the config profiles again tomorrow, but anyone else seen this issue? It doesnt evan appear after a restart like the old clients did

Contributor III

It's working fine for me and we are using azure. Try resetting the login screen using the authchanger command.

New Contributor

@SCCM YES we are seeing this here too - putting 2.3.2 back in our prestage now.

Contributor III

looks like it works fine with macos 11.4 it was having a issue with 11.2.3, but you cant choose what out of box macs come with so we might roll back too