Adobe Creative Cloud Cleaner / Self Service.

Contributor III

I am trying to help my techs with some self service tools for when a CCP adobe installer inevitably fails. I found this and ran this:

/Users/Shared/MacSupport/Adobe Creative Cloud Cleaner Creative Cloud Cleaner Tool ‐‐removeAll= CREATIVECLOUDCS6PRODUCTS

but I still have to interact with the application. I haven't tried accepting the license first, figured I'd mine jamfnation first to see if anyone has put this into action.


Contributor II

I can tell you from experience that the Creative Cloud Cleaner is incredibly unreliable and most of the time for me it either didn't even see Adobe software on our machines and if it did it didn't even remove the /Applications/"App." To properly remove Adobe products from our machines with out reimaging I had to use composer to capture installed files and then write a custom script to remove all Adobe software so that a newer version with a new license could be installed. I called it the Adobe NUKE hehe.

I have seen discussion regarding how to make this run in quiet mode but never really saw much of a solution. Not to be a negger but IMO I think you will be wasting your time with CC Cleaner and will be disappointed with the result. My suggestion is to write a script.

New Contributor III

@djdavetrouble I am in the same boat. I'm trying to find a tool or/and script or something better to set up for JSS to go out and hunt for the older version of the software. I have tried below screen shot. Thinking it might work f616173746b645feb5585487dd1e75e0

New Contributor II

Does anyone have a sample script for removing older versions of various Components ( preferably with logging? ) I am trying to figure out a way to remove older versions of Photoshop before installing a new package, and would prefer to run the script silently during Pre install Any assistance would be greatly appreciated, I am new at this :)

Contributor III

There are a few threads on this topic. For example, you may want to take a look at [](link URL). Please test.

New Contributor

The following worked for me:

sudo /CleanerTool/Adobe Creative Cloud Cleaner Creative Cloud Cleaner Tool --removeAll=All

Hope this helps!

Contributor II

@shriver Interesting, When I run the command it opens in UI mode, and requests the EULA agreement to be agreed

attempting the XML path option, runs in silent mode, but wont run cause it wants the EULA agreement to be agreed to, I have since opened a forum post with adobe regarding the issue.

Contributor II

Within the creative cloud cleaner app there is a xml that appears to list every known file and path from installation.
I hope to script something soon which will remove it, seeing that adobes website claims you can do a terminal silent uninstall using the creative cloud cleaner app, but it doesn't work as it prompts for EULA in both suggested formats prefix and xml code.

Contributor II

After pulling apart the creative cloud cleaner Xml I was able to put together the following:
Note this will blow away flash and other adobe web plugins, but you may consider changing some of the entries below to support your needs.

sudo rm -rf "/Applications/Adobe "*
sudo rm -rf "/Applications/Adobe"
sudo rm -rf "/Applications/DynamiclinkSupport"
sudo rm -rf "/Applications/Nimbus"
sudo rm -rf "/Applications/UniversalFiles"
sudo rm -rf "/Applications/Utilities/Adobe Application Manager"
sudo rm -rf "/Applications/Utilities/Adobe Creative Cloud"
sudo rm -rf "/Applications/Utilities/Adobe Installers"
sudo rm -rf "/Applications/Utilities/Adobe Utilities-CS5.localized"
sudo rm -rf "/Applications/Utilities/Adobe Utilities-CS5.localized"
sudo rm -rf "/Applications/Utilities/Adobe Utilities.localized"
sudo rm -rf "/Applications/Utilities/Adobe Utilities.localized"
sudo rm -rf "/Applications/Utilities/Adobe Utilities.localized"
sudo rm -rf "/Applications/Utilities/Adobe Utilities"
sudo rm -rf "/Library/Application Support/Adobe"
sudo rm -rf "/Library/Application Support/Mozilla/Extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{01A8CA0A-4C96-465b-A49B-65C46FAD54F9}"
sudo rm -rf "/Library/Contextual Menu Items/ADFSMenu.plugin"
sudo rm -rf "/Library/Internet Plug-Ins/AdobeAAMDetect.plugin"
sudo rm -rf "/Library/LaunchAgents/com.adobe."*
sudo rm -rf "/Library/LaunchDaemons/com.adobe."*
sudo rm -rf "/Library/Preferences/com.adobe."*
sudo rm -rf "/Users/$3/Applications/Adobe"
sudo rm -rf "/Users/$3/Library/Application Support/Adobe Device Central CS4"
sudo rm -rf "/Users/$3/Library/Application Support/Adobe"
sudo rm -rf "/Users/$3/Library/Application Support/Adobe"
sudo rm -rf "/Users/$3/Library/Application Support/Flash CS4"
sudo rm -rf "/Users/$3/Library/Application Support/Flash CS5"
sudo rm -rf "/Users/$3/Library/Application Support/Macromedia"
sudo rm -rf "/Users/$3/Library/Application Support/Thermo/.metadata"
sudo rm -rf "/Users/$3/Library/Application Support/Thermo/configuration"
sudo rm -rf "/Users/$3/Library/Application Support/Thermo/p2"
sudo rm -rf "/Users/$3/Library/Caches/Adobe/Typequest/Adobe Illustrator 23"
sudo rm -rf "/Users/$3/Library/Group Containers/Adobe"*
sudo rm -rf "/Users/$3/Library/LaunchAgents/com.adobe."*
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Captivate 10.0"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Captivate 11.0"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Captivate App Packager"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Device Central CS4 Prefs"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Fireworks CS3"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Fireworks CS4"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe HeadLessCaptivate 10.0"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 18 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 19 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 20 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 21 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 22 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe Illustrator 23 Settings"
sudo rm -rf "/Users/$3/Library/Preferences/Adobe"
sudo rm -rf "/Users/$3/Library/Preferences/Flash 10 MRU"
sudo rm -rf "/Users/$3/Library/Preferences/Flash 11 MRU"
sudo rm -rf "/Users/$3/Library/Preferences/Flash CS4 Preferences"
sudo rm -rf "/Users/$3/Library/Preferences/Flash CS5 Preferences"
sudo rm -rf "/Users/Shared/Adobe"

it seems any ~/library reference has to be the absolute path if your testing it via terminal.

Contributor II

This Post can be deleted

Contributor II

This post can be deleted

Contributor II

When Running the adobe script for looking up software it everytime prompts for users to agree before the XML file is created. Is there anyway an option to build in that it don´t prompt for this

Here is the script that generates the XML - but before it generate it it prompt for user to accept

sudo /Users/Shared/Adobe Creative Cloud Cleaner Creative Cloud Cleaner Tool --createCleanup=/users/shared/


When the Adobe CC Cleaner command line works, it should return Exit Code: 0 and run silently without any GUI. You can confirm via the log file ~/Library/Logs/Adobe Creative Cloud Cleaner Tool.log where you will see Mode=Silent mode

However, if you see the GUI, then it did not like the command line parameters you provided. In the log file you will see ERROR: This version of cleaner tool supports silent mode only for CS3, CS4 or CS5-CS5.5 products. Falling back to UI mode. and Mode=UI mode.

These are some of the product parameters I have found that the command line will accept:

# Product=All
<...>  --removeAll=ALL
# Product=Creative Cloud 2017, 2015, 2014, Creative Cloud & CS6 Products
# Product=CS5-CS5.5
<...>  --removeAll=CS5-CS5.5
# Product=CS5-CS5.5-CS6
<...>  --removeAll=CS5-CS5.5-CS6
# Product=CS6
<...>  --removeAll=CS6