AnyConnect Socket Filter on Big Sur

Contributor III

I have seen several discussions on this topic but so far following them I have not been able to get rid of the Cisco AnyConnect Socket Filter PPPC pop. I have a few configuration profiles for AnyConnect following other people and Ciscos generic documentation and it looks like they have installed correctly. However the popup persists. Anyone got any ideas?







Contributor III
Contributor III

It looks like you have a typo in the Socket Filter Bundle Identifier. It should be Try changing that and see if makes any difference.

Contributor III

@RBlount I fixed that but it still wont move past "activated waiting for user". I copy pasted Socket Filter Designated Requirement so that should be right.



New Contributor

This is related, but not exactly the same thing. Are you aware if there is a way to either delete the socket filter on install, or use jamf to remove it completely? We are running into an issue where the Anyconnect socket filter in causing issues when it is installed on systems with SEP installed. The socket filter on Anyconnect doesn't like having the SEP socket filter installed too. We have to have the SEP one per organization ISO, and manually removing the Anyconnect one on each mac is proving troublesome.

Contributor II

only difference I can see is that in our identifier its:
Attaching our info.

New Contributor II

there is a difference, filter Order is set.

New Contributor II

Is the System Extension in a different config profile? Probably need both to get it approved without user interaction.

Valued Contributor II

we're experiencing similar issues. I went through and changed per the suggestions above, but still doesn't seem to want to enable it automatically (still prompting the user).

I also went through this KB article and at the bottom is the text for their premade mobileconfig, which I put into jamf and it still prompting.

New Contributor II

Deleting these worked for me. AnyConnect still works fine.

/Library/LaunchAgents/ /Library/LaunchDaemons/ /Library/LaunchAgents/

You might be able to get away with deleting just the last one, though.

EDIT: Confirmed that this is the only one you need to delete:



This was added o install script to prevent RunAtLoad (startup) >

rm -f /Library/LaunchAgents/
echo "Prevent RunAtLoad"

New Contributor III

Anyone having any luck with a silent uninstall?


Is throwing a user-prompt to remove content filter.

I know this is a bit late but this might be useful to some: I got rid of the Secure socket message during Uninstall:
In my use case I needed the AnyConnect app to be force quit before, you can comment that line out if not needed.



#Force Quit AnyConnect
pkill -x "Cisco AnyConnect Secure Mobility Client"

# get the current user
loggedInUser=$( echo "show State:/Users/ConsoleUser" | scutil | awk '/Name ‌‌"> && ! /loginwindow/ { print $3 }' )

# test if a user is logged in
if [ -n "$loggedInUser" ]; then
# Run Uninstall script as end user
uid=$(id -u "$loggedInUser")
launchctl asuser "$uid" sudo -u /opt/cisco/anyconnect/bin/
echo "no user logged in, Cannot Uninstall"

exit 0