App "stuck" in Self Service

stvkellogg
New Contributor

I apologize in advance if this issue has been dealt with in a different discussion.

I'm running JSS 9.4.rc3 and have an iPad with an app "stuck" in Self-Service. The progress indicator spins but the app doesn't get installed. I've removed the device from the app scope, even un-enrolled the device and re-enrolled it, but when I put it back into the scope for the app I get the same behavior. I've even tried using a different Apple ID, which fixed an installation issue with a couple of apps acquired directly from the App Store. If anyone can provide a suggestion as to how to correct his problem I would be grateful.

Thanks,

Steve

9 REPLIES 9

landerson
New Contributor

I'm having the same issue, I've un-enrolled the device. So close but frustrated as the app pushed out successfully to one iPad. I'm thinking it has something to do with the fact that I had two ipads with the same name. I've renamed the device and still no luck.

Johnny_Kim
Contributor II

I've had a similar issue with OS X 10.9.4 with JSS 9.31.

chlaird
New Contributor III

I've seen it on dozens of devices. No idea what causes it, but it's a major problem. The only workaround we've seen is to go into the JSS, find the ipad in mobile devices, and (i think I have this right) go to the History tab, then Apps, then Pending, and clear them.

When you have 50 devices doing it at once, it takes forever. Completely unacceptable, but like I said, major problem.

landerson
New Contributor

I finally cleared out the pending, it helped. I don't have a good workflow yet for pushing out apps.

tadholyfamily
New Contributor

Posted a relevant feature request for a clear all pending button. https://jamfnation.jamfsoftware.com/featureRequest.html?id=2555

landerson
New Contributor

It's working, thanks for the information!!!

cdenesha
Valued Contributor II

I just created an FR to do it automatically: https://jamfnation.jamfsoftware.com/featureRequest.html?id=2953

dsitter
New Contributor

I've got purchased VPP apps stuck in pending. I clear out the orders in jss and then they change to Install. I click on those and then they just go back to pending. Any suggestions?

cdenesha
Valued Contributor II

I assume it is working for some iPads and not others?

When looking at the user assigned to the iPad, does it show True that 'the device assigned to the user is logged in to iTunes with the Apple ID that was used to register with VPP'?

What iOS version is installed on the iPads in question? Are they Supervised? Do you have one in front of you when you test it? If so, do you see any prompts pop up or partial/stuck installs?

thanks,

chris