Can't repair disk permissions in macOS Sierra

New Contributor

I have the macOS Sierra GM installed on a VM and any time I run the command:

sudo jamf fixPermissions -verbose

I get an error:

Fixing Permissions...
 verbose: Error executing command: (

I'm currently on JSS 9.96.1472575603.c and running that same command works on 10.11


Contributor III

The repair_packages binary is not in the /usr/libexec folder on 10.12.

View solution in original post



I'm running JSS 9.81 and when I run the command on my GM of macOS Sierra, I only get "fixing permissions" and immediately, a new command prompt. There is no error message when in verbose mode. I assume it failed as well.

Beginning with OS X 10.11, permissions repair is no longer necessary as they are protected with SIP. I'll try it on a 10.11 machine out of curiosity.

Valued Contributor II

This works on 10.11.x, haven't tried it on 10.12 yet:

/usr/libexec/repair_packages --repair --standard-pkgs --volume /

Contributor III

The repair_packages binary is not in the /usr/libexec folder on 10.12.

Contributor II

@ClassicII Ok the package is not in /usr/libexec .

Great but that is not a solution..

we are running JSS 9.96 and the last enrollment policy is fixing disk permission. And this error pops up. So as far as this goes, JSS is not setting this function up correctly and it needs te be addressed as I cannot change anything within the Casper Suite to change this. |(other than disabled the Fix Disk Permission)

Edit: It is not working in Mac OS Sierra! El Capitan has no problems.

Contributor III

For MacOS Sierra, there is an undocumented terminal command that will repair user permissions that I found on Apples Support Notes.

diskutil resetUserPermissions / `id -u`

New Contributor II


Have tried running this from Jamf? I was wondering if I should remove u -id when running from jamf.