Casper Imaging Errors

Not applicable

I am seeing a some errors with Casper Imaging v7, that have just cropped
up in the last few hours, and I am at a loss on how to resolve them...

When netbooting a machine with a Casper NetInstall image, Casper Imaging
opens and one of two things happens...

• I go thru Casper Imaging, select my options, and when I select an Install Configuration, I immediately get the following error message: • An excetption of class NilObjectException was not handled. The application must shut down. • I hit • OK • , I am dropped into a Terminal window, I need to restart, and I get the same error the next time I go into Casper Imaging.

If that doesn't happen, as soon a the NetInstall imagine loads, and Casper Imaging launches, I get an • Error parsing xml for Autorun • message. And again, upon hitting • OK • , I am dropped into a Terminal window and need to restart.

I have tried everything I can think I am wondering if anyone has
seen this issue or experienced this issues, or just has any ideas...


Steven Diver, Network Manager
Adlai E. Stevenson High School /
Email: sdiver at / Phone: 847.415.4304

"Be not simply good, be good for something."
-Henry David Thoreau (1817-1862)



I have a ticket open for the "NilObjectException was not handled" error, I am only seeing it at the very end of the install.. seemingly as Imaging is creating the login hooks

I am only seeing this error on PPC machines.


Yea I see at the end when it's creating the first run script

The only thing I could do was boot from DVD and erase the hard disk

Honored Contributor

When I have seen that error message it was due to it not being able to mount the proper casper share. So here is the obligatory gotta ask question....Are your shares all set up with proper permissions/ACLs for your casper read/write and your casper read only accounts?

Just my experience when I saw that error message.



Luckily (I think) it seems to lay down 99% of the image... it just sort of skips the bind to OD, name, and a few minor scripts I run at the end.. Annoying but not a show stopper. It would be interesting if its failing at different points in the process for different people's builds.


that was my first check... permissions and/or me forgetting to replicate :- this time of year I am making constant tweaks to the Admin.

All my intel machines are imaging from the same shares with no error.. So I was leaning towards an architecture thing.

Not applicable

No ACL on my share points. Permissions appear correct to me, or at least
they are the same on both...

casperadmin Read & Write
staff Read Only
others Read Only

or in POSIX format...

drwxr-xr-x+ 7 casperadmin staff 238 Jun 29 10:57 CasperShare



I get it if the computer drive name is not same as in the autorun


That sound like me, it fails at the first run script, the bind etc , plus the adobe, all od which I need, but it's random and only about 5% of the time,

I'm only fix was a boot from DVD and disk erase

Honored Contributor

I have a first run script that wipes out all partitions, and I suggest everyone does this, since the erase drive option only formats and doesn't lay down a new partition.

Also, make sure your passwords are correct for all your accounts, because if I recall, when I saw that problem it was due to me changing a password and the accounts didn't match so they couldn't authenticate.




I've not changed by passwords

But under Casper 6 I had a partition script that created a windows script, now that's in Casper 7 I I stopped using it, but I might go back to it now


New Contributor

I was seeing the same two errors, but Jamf Support was able to find the
cause of one, and I figured out the other:
Error parsing XML: This was due to an incorrect password stored in the
autorun data for the computer I was imaging. I had changed a JSS account
password. The solution was to delete the autorun data in the JSS.

NilObjectException: According to Jamf Support, this is caused when a
non-deployable package is part of a configuration in Casper Admin. The
solution is to remove/delete the non-deployable package from that config and
then try it again. I haven't verified this yet, but it sounds likely since
the only thing I had changed was to make a deployable package


Tatian Greenleaf
Associate Director of Technology
Saint Mark's School
(415) 472-8000 x1014


Sounds good , unfortuneatly non of those ar true in my case

Not applicable

Could you post a copy of the script you created to wipe out all of the partitions? We have been dealing with the NilObject error on our PPCs as well.


I am seeing this error as well "An excetption of class NilObjectException was not handled". I get when using Casper Imaging 8.61 and it shows up after trying to add a computer name. Then the Application shuts down. Any idea of how to get this to stop happening?

New Contributor

I was able to fix it by targeting the computer and repairing permissions - it repaired several java items.

New Contributor

Go into your Admin tool, and verify that your OS.dmg is set up correctly (priority 1, correct file, etc) and then if you have a Recovery Partition ensure that is set up as well ( My issue was that the recovery partition was set to priority 10, didn't have the right file, it was a mess. Now that I fixed my Recovery Partition, its working.